Hassat Hunter

Bug Reports for TSLRCM 1.8.6 (PC)

Recommended Posts

Here's the place to report bugs, errors with other mods etc.

NOTE: Only report issues here if you use the latest version of TSLRCM (1.8.6) on the PC! If you don't, please update to the latest version of TSLRCM! They very well might resolve your issue.

When posting an issue, be able to state with your issue the following information (stolen from a wonderful post by Darth InSidious) . . . which I've amended.
 

Quote

1) When did the problem begin to occur?
2) Did you install the latest version of the mod?
3) What version of the game do you have? (Steam, 4CD, KotOR Collection?) What region is the game designed for if it's the 4 CD version?
4) Did you update your game as required by your game's region?
5) Did you install this over the previous version(s), or did you perform a fresh installation as required by the TSLRCM's read-me file?
6) What other mods did you have installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)
7) Can you be more specific about the error? At what point did it happen?
8 ) Have you tried re-downloading the mod?
9) Have you tried using a different save game?
10) Have you tried starting a new game?
11) What Operating System do you use? (List Virtual Machines as well if you are using them.)

Include these questions with your answers, please.

 

This is now a requirement for bug posting. Thank you for your continued patronage.

  • Sad 1

Share this post


Link to post
Share on other sites

I can't install TSLRCM 1.8.6 to the DVD version of KOTOR 2.  When I run the EXE file, it installs automatically to GOG Galaxy even though I don't have that version of KOTOR 2 installed.  Even if I delete the main GOG folder, the installation makes a new one anyway.  Is there a way to choose which folder I want to install to?  I'm running WIN10 and have no other mods installed.

  • Like 1

Share this post


Link to post
Share on other sites

Mandalorian Battle Circle will not proceed past first opponent.

1) When did the problem begin to occur?

Mandalorian Battle Circle

2) Did you install the latest version of the mod?

Yes

3) What version of the game do you have? (Steam, 4CD, KotOR Collection?) What region is the game designed for if it's the 4 CD version?

Steam

4) Did you update your game as required by your game's region?

I downloaded it from Steam so I assume it updated to the most recent patch.

5) Did you install this over the previous version(s), or did you perform a fresh installation as required by the TSLRCM's read-me file?

Installed over 1.8.5

6) What other mods did you have installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

Tried with quite a few mods at first then uninstalled them all and the problem persisted. 

7) Can you be more specific about the error? At what point did it happen?

After killing (this may be a problem as you’re not supposed to be able to kill them) the first opponent and talking to the sergeant he states that I will fight the first opponent, but because I have already defeated the first, nothing happens.

Edit: I ended up having to start a different playthrough due to a different game breaking bug. (Game crashed when trying travel to Korriban. Solution was to do Korriban before Dxun/Onderan.) In this playthrough I noticed that the first opponent did not use a sword, whereas when the bug occurred he was always using a sword. This somehow lead to him not dying when he was defeated, and I was then able to proceed to the second opponent.

8 ) Have you tried re-downloading the mod?

Yes

9) Have you tried using a different save game?

Yes

10) Have you tried starting a new game?

Considering how far in I am, I’m not willing to try this

11) What Operating System do you use? (List Virtual Machines as well if you are using them.)

Windows 10

As a side note I have a save right before initiating the quest that I can proceed with and test if works whenever there is an update or potential fix. I’ll just not start it so I can go back later. 

Edited by Kimosabe
Additional Information Discovered

Share this post


Link to post
Share on other sites
Posted (edited)

Background music interrupts seem bugged. Near the start of the game, the player has the option of checking the hatch to the Peragus Mining Tunnels turbolift only to find that it is sealed. This is typically met with a quick telepathic dialogue from Kreia and a (loud) momentary change in background music. After the sound and the dialogue finishes the Peragus theme is supposed to resume playing on a loop....But it doesn't. The short (loud) music segment from the cutscene just keeps looping in its place throughout the rest of the level, and is really distracting as it drowns out the speech of any dialogue playing in the foreground. I haven't played beyond this to check to see if it affects other bg music interrupts since I just get too annoyed to continue. I tested the same settings on the vanilla version of the game with default settings (and tested my personal preference settings) and it functions normally.

Edit: I would also like to add that, after testing a comparison of a vanilla game with the TSLRCM 1.8.6 modded version again, I've noticed two issues the mod introduces.

1. Unlike the vanilla fresh install, the mod requires me to enable VSync after combat to move the player at all. (In case knowing this helps identify the bigger issue, I can work around this one)

2. If I load a save of the modded version of the game (from the same install) that is from a point after this sound glitch is triggered, the glitch persists after the game loads. So no getting around it that way. (Because it persists into the save files, I'm going to include two here to help with troubleshooting, one from before the trigger(Game 1), and one from after(Game 2).)

Okay, this solution seems to be specific to the Steam version (though I'm not sure why). -When the first psychic encounter cutscene with Kreia occurs, immediately choosing the second dialogue option results in the glitch I described. Choosing the first option that extends the interaction by one exchange successfully refreshes the Peragus background theme in its loop. Further triggers for this music clip (such as the passive precognition cutscene soon after) do not cause the glitch. And this is with the TSLRCM installed.

1) When did the problem begin to occur?

-With v1.8.5 around November 2020 and persistent today with v1.8.6. I've played the TSLRCM before on the older versions on another PC and haven't encountered this issue. Though not on my current newer PC.


2) Did you install the latest version of the mod?

-Yes. Thirty minutes before posting this.


3) What version of the game do you have? (Steam, 4CD, KotOR Collection?) What region is the game designed for if it's the 4 CD version?

-GOG


4) Did you update your game as required by your game's region?

-As it is a fresh install (today) with auto updates, I presume so.


5) Did you install this over the previous version(s), or did you perform a fresh installation as required by the TSLRCM's read-me file?

-Fresh install.


6) What other mods did you have installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

-Only M4-78 to accompany TSLRCM, though I've tested this without M4-78 and reach the same bug.


7) Can you be more specific about the error? At what point did it happen?

-Always at the same point. Totally reproducible.


8 ) Have you tried re-downloading the mod?

-Yes, many times.


9) Have you tried using a different save game?

-Typically test with fresh games since it happens early enough to be feasible.


10) Have you tried starting a new game?

-Almost exclusively.


11) What Operating System do you use? (List Virtual Machines as well if you are using them.)

-Microsoft Windows 10 v2004

Specs

  • CPU: AMD Ryzen 5 3600 6-Core Processor
  • Memory: 16GB
  • GPU: Gigabyte NVIDIA GeForce GTX 1050 Ti
  • Display Mode: 1920 x 1080 @ 60Hz

Note: OS is installed on M.2 SSD with game and mod installed on separate HDD.

 

saves.zip

Edited by TheCOPRCollection
Providing possible solution for Steam version only.

Share this post


Link to post
Share on other sites
Posted (edited)

Game will not progress past the point in the picture. Carth walks to that point and looks around forever. I know the game isn’t frozen because he continues to turn his head and look around. 
1) When did the problem
 begin to occur?

After a cutscene of the Republic Fleet arriving at Citadel Station.

2) Did you install the latest version of the mod?

Yes

3) What version of the game do you have? (Steam, 4CD, KotOR Collection?) What region is the game designed for if it's the 4 CD version?

Steam

4) Did you update your game as required by your game's region?

I assume Steam did that for me.

5) Did you install this over the previous version(s), or did you perform a fresh installation as required by the TSLRCM's read-me file?

Fresh install

6) What other mods did you have installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

Tried with an assortment of mods but uninstalled all in hopes this would fix the issue. It did not.

7) Can you be more specific about the error? At what point did it happen?

See included picture.

8 ) Have you tried re-downloading the mod?

Yes

9) Have you tried using a different save game?

Yes

10) Have you tried starting a new game?

Unwilling to at this point in the game

11) What Operating System do you use? (List Virtual Machines as well if you are using them.)

Windows 10

219A7C4D-30ED-4925-8FE8-C9435B23EEBA.jpeg

Edited by Kimosabe

Share this post


Link to post
Share on other sites
5 hours ago, Kimosabe said:

6) What other mods did you have installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

Tried with an assortment of mods but uninstalled all in hopes this would fix the issue. It did not.

9) Have you tried using a different save game?

Yes

10) Have you tried starting a new game?

Unwilling to at this point in the game

 

Let me see if I've got this straight - and please, correct me if I have any of this wrong...

  • You modded up your game with many mods - none of which you've listed. (Listing all mods is required.)
  • Then - you uninstalled those many mods (excepting TSLRCM) - without starting a new game. 

Is that about right?

Edit: I'm going to head off to sleep right now. If @Kimosabe answers in the affirmative to both of the bulleted lines above before I get back, please feel free to jump in and explain why deleting several mods in the middle of a playthrough might be . . . problematic.

  • Like 1
  • Light Side Points 1
  • Dark Side Points 1

Share this post


Link to post
Share on other sites

@Kimosabe Sith Holocron has a point in the questions he's asking to clarify things.

The way most mods that aren't just models or textures work involves adding data that's saved into games (like creatures in areas, or variables used to reference the state of progress in the game) or altering existing files.

Simply uninstalling a mod (this by itself can be problematic if the mod changes data inside the packs for a level or area) doesn't guarantee that its effects are gone from your save.

So uninstalling the mods and not fixing the issue isn't too surprising, but to have a chance to help, we need a list of your mods (perhaps a screenshot or two of the packaged files [the .zip, .rar, or .7z] from your Downloads?) to be able to begin helping. Otherwise, we literally can't diagnose what went wrong...

  • Light Side Points 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.