Recommended Posts

KOTOR 1 Community Patch

The K1 Community Patch (K1CP) is a compilation of previous bugfix mods and some new original fixes put together with the intention of resolving the many and various issues that KOTOR has. This includes some well-known game breaking bugs/softlocks, broken quests, inaccessible content, as well as lesser issues such as problems in conversations, visual inconsistencies, player annoyances, etc. The intention is for the changes to be as seamless as possible, fixing and improving things whilst still retaining the original developer intent.

A huge thanks to all of the mod authors who created these mods, and allowed them to be included in this patch! Unfortunately, the individual list of changes has grown too long to be included in this post, however you can view a detailed breakdown of each author's contributions in the included readme file and a list of the changes the current version has made in the changelog file.

List of Contributing Authors (alphabetical):
A Future Pilot









Kainzorus Prime


KOTOR 1 Restoration Team


Markus Ramikin


ndix UR


Red Hessian


Thrak Farelle

Run INSTALL.exe and navigate to your K1 install folder. Generally speaking, this mod should be installed before anything else, except mods that do hard edits/overwrites of 2DA, TLK or MOD (module) files. Due to the size and complexity of the patch, installation will take several minutes. Please be patient and allow it to finish.

Warning: Never run the installer from inside the archive! Always extract the archive onto your hard drive first.

It is highly recommended that you do not install the game on your system's C drive, especially in Program Files. Windows can have permissions issues when trying to install the mod to a C drive destination. If you are using the Steam version of the game and have installed Steam in its default Program Files location, we advise creating a new Steam Library on a different drive and moving the game there via the game's Properties pop-up in Steam.

Compatibility/Known Issues:
K1CP uses module injection in an attempt to remain as compatible as possible with other mods. This may result in issues with mods that simply put files in the Override folder. It is recommended that you consult the individual authors of any large scale mods, particularly those that edit DLGs and scripts, as to whether their work is compatible with K1CP. Some mods will likely require updates, some may need to be installed in a specific order, whilst others may be fundamentally incompatible.

The KOTOR 1 Restoration (K1R) mod is deemed incompatible with K1CP. Whilst it was compatible with early versions of K1CP, this is highly unlikely to still be the case with the degree and nature of changes made as of K1CP v1.8 and beyond. As such, using K1R together with K1CP is done so at your own risk with no support offered.

These are the currently known bugs/issues with KOTOR or the mod that the K1CP is looking to resolve:

If you find any others, especially with changes/additions K1CP makes, please report them on the Github issue page or here on Deadly Stream so they can be addressed. Be sure to include as much information as possible, including a list of all the other mods you have installed, the order you installed them in, steps to reproduce the problem, along with screenshots and save files, if appropriate. You may also be directed to provide the TSLPatcher installlog file, a list of the contents of your Override folder, and specific MOD files from your modules folder.

Given the complexity of this mod, a clean install of KOTOR is the only practical approach for uninstalling K1CP.

Due to this mod being a compilation from many different authors, please do not distribute/rehost it.


  • All of the mod authors who have helped make this patch a reality - thank you! - especially for agreeing to distribution outside of Deadly Stream
  • Fred Tetra - For KOTOR Tool
  • tk102 - For DLGEditor and K-GFF
  • JdNoa/Dashus - For DeNCS
  • Stoffe - For TSLPatcher
  • bead-v - For MDLEdit and KOTORMax
  • ndix UR - For TGA2TPC, TPCView, and MDLOps v1.0+
  • seedhartha - For KOTORBlender fork for Blender 2.8+
  • Fair Strides - For various tools and updates to older tools
  • DrMcCoy - For Xoreos Tools
  • Snigaroo - For maintaining mod builds on the /r/kotor subreddit
  • danil-ch - For the original info.rtf template
  • Many thanks to ebmar, Salk, and KnifeMaster for providing numerous bug reports and beta testing certain fixes




  • Like 3

Share this post

Link to post
Share on other sites

Let's hope this is the right place to discuss.

I just ran into a rare bug with Canderous' personal quest, where the final conversation wouldn't trigger (the "I'm not happy with the way my life has turned." one).

It has to do with the mechanism which triggers these(where you need to level up to trigger the next), and it makes me think this is not a bug unique to this conversation, but based on the mechanism.

The triggers for these convos often include the following condition (i.e. check some global against your level):

(GetHitDice(GetFirstPC()) > GetGlobalNumber("T_LEVC"))

Which fails if that global number is 20.

It should probably be changed to something like:

((GetHitDice(GetFirstPC()) > GetGlobalNumber("T_LEVC")) || GetHitDice(GetFirstPC()) == 20)

The fix is simple, but tracking down all instances might be tricky.

  • Like 1

Share this post

Link to post
Share on other sites

I recently downloaded the 1.8.1 version and the game crashes after the character creation. Is their something I need to do differently to get it to work in Steam?

Share this post

Link to post
Share on other sites

Having a problem with the install its indicating that it cannot find  "Temp2_K1 Community Patch\tslpatchdata\hijata.utc". The system cannot find the file specified (EXT-0)" Ive unzipped the file into the directory and run the installer but it continues to run into this problem. Anyone have a fix?

Share this post

Link to post
Share on other sites


I am curious about the decision to include some textures in the Community Patch. I am talking about commoners' clothes, in particular N_CommF01, N_CommM01, n_commf07 and n_commm07. I like the new textures but it doesn't seem the original ones were flawed in any way (other than legitimate concerns about the aesthetics). Or was there something wrong with them?


Share this post

Link to post
Share on other sites

Don't know if this is the right place to post this, but here goes:

After playing with the latest version, 1.9.2, this mod is nearly perfect. Congrats and many thanks to the whole K1CP team!

I know you're continuing to improve this patch and after my last play with it I'd like to add my two cents.

If the things reported below are bugs or deserve fixes or adressing in some manner it's up to you, of course. I trust your insight and decisions.


Ebon Hawk:

- after the very first travel with the Hawk leaving Dantooine, Zaalbar tells the player about some missing supplies in the cargo hold; there's a pop up signaling a journal update, but no entry in the log, only after checking the supplies.



- there's some party banter facing issues after helping Sharina Fizark (and come to think of it probably if robbing her too, have not tested de DS option);

- Zoriis Bafka (swoop racer) is on a combat suit.



- Zaalbar does not have is equipped items when captured by Chundaar (I guess it makes sense for Chundaar to strip him of his gear, but if that's the case then Zaalbar should not have any weapon equipped, as he shows holding up a plain sword; did K1CP team made this change so that Zaalbar would not go madclaw on Chundaar a second time? But why would Chundaar care about that? And again if that were to be the case it would only benefit Chundaar on his fellow wookie's eyes. I really think this is an "all or nothing" scenario: Chundaar allows Zaalbar to keep his gear showing his 'good faith' or totally removes it until the issue in the Shadowlands is resolved in his favour);

- the party can not transit back to the Ebon Hawk after liberating Edean from the Czerka (probably this change was made so the player is forced to confront the Czerka enforcers and although I agree with it to some extent, it's really a drag to not be able to transit back at that point)



- entering the Leviathan's bridge the party has no weapons equipped (I understand that this is probably related to the unmasking of companions for a more cinematic feel and one can not be made without the other, but it just seems odd to enter what you know is going to be a physical confrontation without weapons ready).


And that's it. As stated earlier, I trust in your insight and decisions of what to do or not about this. Just trying to help.

Thank you so much to the K1CP team and all modders of this site. I love this community.

Share this post

Link to post
Share on other sites

Hi, I need some help. I tried installing this mod because i really NEED it but it keeps failing saying theres an error with some files each time. I locate the file and the only thing i can see is that it doesnt have special permissions ticked (i dont know if that helps) im just lost for what to do.

It just keeps saying access denied.

Share this post

Link to post
Share on other sites
Guest Qui-Gon Glenn
On 3/3/2023 at 3:11 PM, UnflappableWoppy said:

Hi, I need some help. I tried installing this mod because i really NEED it but it keeps failing saying theres an error with some files each time. I locate the file and the only thing i can see is that it doesnt have special permissions ticked (i dont know if that helps) im just lost for what to do.

It just keeps saying access denied.

Edit - I think we solved this one :)


I just finished a playthrough, and had some issues with Juhani that ended up being trivial, but I was unsure if they were a result of one of the Juhani mods I had installed following the build guide, or an actual issue in K1CP. Specifically, my Juhani wore special robes once she was a party member, they had slots for armor upgrades. It was a decent look and OP performance-wise, so I left it in but was never sure if this was intended behavior for the @Snigarooguide.

Later, I had an issue with Xor spawning on Tattooine at the landing pad... He and his geeks were waiting for Juhani, the bark correctly said as much. I brought Juhani out, they didn't go hostile, left the area and came back, they didn't go hostile so I boarded the EH and the game crashed. For the rest of the playthrough, even after killing Xor on Manaan, Xor's ghost and his henchman remained on the Tattooine landing pad, I even think his ghost went to an "injured" state after we had dispatched him. I do have a couple saves for this if that is something anyone cares about. I followed the most recent build guide to the letter - which took two attempts 🤦‍♂️


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.