Jump to content


Photo

K1R 1.2 Impressions and Bug-Reports [READ ME FIRST]


  • Please log in to reply
129 replies to this topic

#121 rede9

rede9

    Jedi Apprentice

  • Members
  • PipPip
  • 25 posts

Posted 06 August 2017 - 01:03 PM

English

Strange. I have the same problem (missing texts; node errors) with Vulkar Base, but I'm using GOG Italian version. I thought language was the problem.



#122 HDR1

HDR1

    Jedi Apprentice

  • Members
  • PipPip
  • 15 posts

Posted 07 August 2017 - 08:16 AM

1. At the Manaan Swoop Registration Office, Talking to Sslamoth.

 

2. Yes

 

3. Steam

 

4. N/A

 

5. No

 

6. None

 

7. I get an error that says: “CONVERSATION ERROR: Last Conversation node Contains Either an END NODE or a CONTINUE NODE. Please contact a Designer!” After Sslamoth finishes his first line.

 

8. No, don’t want to risk corrupting my game before checking that it won’t

 

9. Yes

 

10. No, it’s too late in the game for me to check it that way.

 

11. Windows 10

 

12. N/A

 

 

I had a look around in some other places but couldn't find any actual resolution to the problem. Don't want to risk breaking my game as I'm quite far in so thought it best to come straight to the source. 

I've had this same exact problem, the only difference being that I'm playing the GOG version. I can't initiate either the Manaan Swoop racing quest or the pazaak tournament because of this. I only have a few cosmetic mods installed, so I doN't think it's caused by a mod conflict. Does anyone have any ideas on how to fix it?



#123 Kexikus

Kexikus

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 1,345 posts

Posted 07 August 2017 - 08:41 AM

IIRC a similar bug (same error message) had been present in Darth Tyren's PartySwap for TSL. I think the cause of the bug back then were non-english game versions that didn't work with the mod, but I'm not sure. I also think he fixed the bug, so maybe he can help?



#124 rede9

rede9

    Jedi Apprentice

  • Members
  • PipPip
  • 25 posts

Posted 07 August 2017 - 03:09 PM

IIRC a similar bug (same error message) had been present in Darth Tyren's PartySwap for TSL. I think the cause of the bug back then were non-english game versions that didn't work with the mod, but I'm not sure. I also think he fixed the bug, so maybe he can help?

Is the error about Pazaak tournament? I played it with non problem with a non-english version.



#125 Kexikus

Kexikus

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 1,345 posts

Posted 07 August 2017 - 03:22 PM

Is the error about Pazaak tournament? I played it with non problem with a non-english version.

 

It's not K1R related at all as PartySwap is a TSL mod. I think there the error came up when going to Iziz with the Mandalorians. But the error message was the same (I think) so the cause for the bug was probably similar as well which is why I mentioned it.



#126 Mr Ardvark

Mr Ardvark

    Jedi Apprentice

  • Members
  • PipPip
  • 15 posts
  • LocationSouth Carolina

Posted 07 August 2017 - 07:58 PM

Some minor grievances & problems I have encountered:

  • On Tatooine, when being approached by the alien that reveals that Helena is in the cantina, Bastilla asks the alien if it has seen her mother before the alien has even started talking. Seems rather strange considering she is now the one who initiates conversation. Also, the cut dialogue in that conversation seems to just be different takes of the original, Bastilla asks about her mother twice now, this disrupts the flow of the conversation, and does not add a new point of view or anything relevant.
  • On Dantooine, when the first group of Mandalorians is threatening the farmer, the Mandalorian will shoot at the iriaz and never become hostile to the player, making the Jon quest line impossible. The Iriaz should be removed from the Matale estate module, and IMO Dantooine as a whole could use a reduction in the population of Iriaz. The Hutt inside of the estate is rather silly and If I had to guess I'd say he was cut for the sake of atmosphere as he is very out of place there.
  • On Lehon, the Sith Beastmaster is keeping Desert Wraid. I don't know how he could keep 2 apex predators the size of speeder bikes content, especially in that tiny room! This also affects gameplay as well, the beasts are too large to maneuver around in there, and can't get around the Sith or each other to attack the player. Something like kath hound or tuk'ata would make more sense to be kept as pets.

~ Signature


#127 Eniena

Eniena

    Jedi Initiate

  • Registered
  • Pip
  • 3 posts

Posted 11 August 2017 - 09:51 PM

Hi. Just wanted to say thank you so much for making such a terrific mod. Really enlivens an already great game experience.

 

I've encountered some noticeable bugs that should be addressed.

 

GENERAL

  • For some reason, the game often minimizes after the Lucasart logo plays when you start up the game. Furthermore it can be impossible to bring the game back up once this happens.
  • The auto-pause option that activates when you spot an enemy doesn't work some times.

TARIS

  • Whenever I fight in the arena, the position my character first appears in is slanted and not directly facing my opponent. This slant actually gets worse and worse with each fight as they twist more and more to the left.
  • After giving Largo the money he needs to pay off his bounty, the camera doesn't focus on Carth when he's giving his response to your generosity.
  • When you discover Rukil's dead apprentice and go back to talk to him about it and go through the conversation you need to go through to really get started on the Promise Land quest, everything is fine. However you'll have to go through the entire conversation all over again which obviously shouldn't happen as it'll usually jump straight past it to a dialogue state that reflects your post-dead apprentice reporting to him.
  • When you go back to the Hidden Bek base after winning the swoop race and go talk to Zaerdra with Mission in your party, the camera won't focus on Mission when she pipes in with her unique dialogue. It'll instead focus on Zaerdra for the line.
  • When you first arrive in the Taris Undercity and have your first meeting with Canderous, one of the black Vulkar thugs is speaking Twilek even despite not being a Twiliek. I'm actually using the Black Vulkar Sound Fix to correct this but, considering the K1R mod also corrects bugs in the game in addition to restoring content, you really ought to consider correcting this bug.
  • For some reason, when I'm in the undercity apartment complex where Selven is, the Vulkar Thugs for some odd reason run to and gather right outside the apartment door she resides.
  • Whenever I reenter the Taris City Sewers, Rakghouls that I've previously eliminated at the juncture with four exits respawn when they shouldn't.
  • When I am in the Vulkar base sub-level and after talking to the elderly Vulkar Mechanic about getting an authorization card, the journal entry for "Inside the Vulkar Base" for some reason reads "Taris: You've lost the tournament and have no credits to show for it..." You'll get the "Taris: You've lost the tournament but managed to win a sizable amount of credits" if you directly take his items straight out of his locker. This continues if you decided to do the spice for mechanic card quest. Obviously these shouldn't be the correct journal entries and definitely need to be fixed.
  • Again, when in the Vulkar Base sub-level and access the main terminal, the camera view "Cam-408: Control Room" in the South Section options is not focused on anything and is WAY outside of the game area and gives an almost full view of the game module.
  • When you use the workbench in the Vulkar Garage even despite using the workbench in your Taris hideout first, you'll still get the message you normally get when using a workbench for the first time.
  • In Davik's Base, if you choose to gas the barracks near the spice lab using the security terminal, you will kill the Tarisian Noble who gives you 5 credits if you pass a persuasion check. Apparently some of the gas you leak into one of the rooms gets into his somehow and kills him.
  • There is still the classic bug that prevents you acquiring the ability to rewatch the Ebon Hawk escaping Taris. I know that this is caused by that FMV being preceded by another without any in-game break at all so the trigger needed to unlock it got pushed properly. This should be a fairly easy fix as you could probably put in a brief in-game scene such as a brief black screen BEFORE that cutscene plays so as the trigger to unlock it in the main menu gets flipped properly.

DANTOOINE

  • On Dantooine the positions of Master Vandar and Shuma the Hutt are very slanted. Vandar is especially bad as when you first encounter him he's looking all the way to the left.
  • Master Vrook and Master Zandar are not wearing their correct outfits. Again this is an oversight that I used the Vrook and Zhar Fix mod to correct.
  • When talking to Elise for the first time about your missing droid, if Carth is in your party and gives his unique dialogue, he for some reason turns the other way while he delivers it.

When I come across any more bugs, I'll just edit this post and add them.

 

Oh, and here is a current list of mods I am using alongside my game, besides the restoration mod of course. Some of these mods, more specifically the ones who solely fix bugs and restore content, I'd highly recommend you implement into the next version of K1R and will mark those with a *.

  • Animated Cantina Sign
  • Animated Manaan Cantina Sign
  • Bastila on Korriban*
  • Bek Control Room Restoration*
  • Bendak Bounty Rework
  • Black Vulkar Sound Fix*
  • Dantooine Training Lightsabers
  • Dark Side Reimagined
  • Davik's Upgradable Armor*
  • Dodonna's Transmission
  • Ebon Hawk K1 Fixes*
  • Feat Progression for K1
  • First Lightsaber Crystal Fix*
  • Force Dustil
  • Force Powers Feat Gain for KOTOR
  • Galaxy Map Fix Pack*
  • Gamorrean Battleaxe Fix*
  • Gamorrean Battleaxe Icon Fix*
  • Gate Guard to Trewin
  • Genoharadan (Light Side)
  • Green Pazaak Base Cards
  • HK-47 Polished Reskin
  • Health Regeneration
  • Helena - Bastila's Mother Changes
  • Hi-Res Beam Effects Mod
  • High Quality Skyboxes
  • High Quality Starfields and Nebulas
  • Juhani Real Cathar Head
  • Kill Belaya
  • Kill Star Forge Jedi
  • Korriban Academy Workbench
  • Leviathan Party*
  • Longer Hair for PFHC01 Female Head Model
  • Mandalorian Assault Armor Restoration*
  • Movement Animation Fix*
  • New Dustil Onasi Head
  • PC Response Moderation (Installed BEFORE K1R)
  • Proper Sith Assassins
  • Quanon's Bastila Shan Reskin
  • Quanon's Canderous Ordo Reskin
  • Quanon's Carth Onasi Reskin
  • Quanon's Gammorean Reskin
  • Quanon's HK-47 Reskin
  • Quanon's Jolee Reskin
  • Quanon's Mission Vao Reskin
  • Quanon's T3M4 Reskin
  • Quanon's Twilek Outfits
  • Quanon's Zaalbar Reskin
  • Red Lightsaber Crystal Fix*
  • Sandpeople Disguise Drop Fix*
  • Sapith Fix*
  • Sherruk Attacks With Lightsabers
  • Simple Weapons Feat Restoration*
  • Sith Lightsaber Replacement
  • Sneak Attack 10 Restoration*
  • Stealthy Droids
  • Trandoshans Rescaled
  • Unique Sith Master Robes
  • Vibrating Saber Colors
  • Vrook and Zhar Fix*
  • Yuthura Sith Eyes with Light Side Transition


#128 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 3,911 posts
  • LocationKodiak, AK (Hoth)

Posted 11 August 2017 - 10:31 PM

When I come across any more bugs, I'll just edit this post and add them.


I'm sure the mod makers will appreciate that but you should probably add to that which other mods you have and a link to where you got them from - just to rule out issues caused by other mods.


"Release dates are for those that don't care about quality in mods." - Me
 
Here are my mods. Please rate and leave some feedback if you've liked any of them in your game!

Not approving mods.  PM one of these other folks if you mod is not reviewed within 24 hours.


#129 Eniena

Eniena

    Jedi Initiate

  • Registered
  • Pip
  • 3 posts

Posted 12 August 2017 - 07:35 AM

That's a good point. I will go ahead and do that.



#130 WhiteFlame1993

WhiteFlame1993

    Jedi Initiate

  • Registered
  • Pip
  • 1 posts

Posted 20 September 2017 - 09:04 PM

Iv ran into a gamebreaking glitch for kotor 1, I spoke with the jedi on dantooine about constructing my lightsaber but the cutscene just pans over to the workbench and thats it, nothing else happens 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users