Leaderboard


Popular Content

Showing content with the highest reputation on 09/21/2020 in all areas

  1. 2 points
    Why is it always you, Juhani?
  2. 1 point
    Update I added some metallic reflection. I tweaked the helmet a bit, mainly made the visor more black. I worked on the 2nd blaster, there's a part on the top that I'm not sure what to add to because I couldn't find decent reference images. I ran into some issues: Mira is wearing the helmet in the screenshot above, her hair is coming through. Probably something that's not easy to fix, the helmet is already quite large. The Handmaiden is in the 1st screenshot. Left image, bottom arrow: there's a streak of pink here, not sure where it's coming from, it's not in that place in the texture. Middle image: that's the top part of the blaster that's a bit empty. Right image: I wanted to keep that part a light metal, but it seems a part from the dark part of the handle is being applied to it and it ends in a diagonal non symmetrical way. The other model/blaster has a similar issue. The way the blasters are held is not great, but that also goes for a lot of vanilla things. I'm attaching all the files (including .psd) you would need to continue (or, feel free to just play with it). I hope someone can carry the torch. TSL_Sabine_Wren_Helmet_Blasters.zip
  3. 1 point
    I wound up testing it myself last night and it seems to work fine, which makes sense I suppose if the file was merely an extracted vanilla .mod file. I was worried that your file was edited in some way that made it different to the one included in the KCP but apparently not. .mod editing, if such a thing even exists, is above my pay grade so I just wanted to be certain that one was no different to the other. Thanks for the responses.
  4. 1 point
    Good question, and can't blame one for that. Long story short, before I know how the patcher works, I thought more/less the same as you -- the installation might not working as intended, and without knowledge for once I copied the MOD file inside a mod archive and then paste-overwrite the existing one inside my modules folder. Fun times, lol. So in general it's best for one to understand it like this -- as DP stated above It still should inject the appropriate changes into that MOD. What happened under the hood is the installer make changes to the already existing relevant MOD/unk_m44aa.mod file on your end, and does not copying what's inside the mod's archive. The opposite happened when -let's say- you have a clean install of the game and this mod being installed first. You will then have empty modules folder filled only with RIMs, without any MODs. What this mod does then it will copy the [vanilla] MOD inside its archive to yours, and then inject the appropriate changes onto it. It's a necessary procedure for the mod to work properly. And to answer the question -- I can only say to install this mod at the latter stage of your build, which means after K1CP and any other mods if necessary. Hoped that helps. Cheers!
  5. 1 point
    There's not a single ready anim, there are multiple different ones to cover the different weapon types. You can use @JCarter426's combat animation guide and TSL's annotated animations.2da to help you find them, but they should be of the form gXrY, where X and Y are numbers that indicate wielding type and anim variation, respectively. For example, g2r1 should be the single saber/sword ready and g5r1 should be the single blaster pistol ready. Some of these appear to be recycled, for example g7r1 (rifle) and g9r1 (heavy carbine) are identical. If you are setting the piggy's anims as unarmed, then they'll presumably need a g8r1 for the ready anim. But since their UTCs force them to use melee anims, I'd just go with that. They obviously already have a limited set of anims by default, so duplicating the existing ones to cover the melee variations shouldn't be too much of a problem. The only question is whether the choreography limits the human anims when fighting a creature, or if it uses the full range of anims regardless. I'm not sure I ever noticed. There's nothing special in the DLG that would suggest the cause. Neither it or the ambush one have any forced or scripted talk anims. I'm not sure why it would work in one scene and not the other. You can export and import a text list of the node mapping, so it might be worth doing it that way to see if that gives you some more control.
  6. 1 point
    Skipping pre-existing MOD files is normal practice. It still should inject the appropriate changes into that MOD.
  7. 1 point
    Yeah that's what I used to fix Malak's animations, it is really useful. I also tried it with the Selkath but it creates a complete mess I don't know exactly why, perhaps I should try again renaming some of the bones since the last time I just did an auto remap without renaming anything. I just checked those and there is a problem with the thugs ambush if you fight them after talking: they are using melee sword combat animations that the piggy model doesn't have because their .utc have the gamorrean axe equipped but I renamed the animations to the melee unarmed counterparts since there are just not enough of them to cover the sword ones. So their .utc would have to be replaced to unequip the axe fixing as well the player reacting with parries and flashes like they had a sword or lightsaber. I also need to mention that all the READY animations the piggies have in convos are not playing because there is not a humanoid counterpart for it (that I know of, correct me if I'm wrong). On top of this there is another problem with Vorn's lines playing the "tlknorm" animation which is supposed to be the default one when nothing is specified in the .dlg file. It just plays the PAUSE1 animation I'm not sure why, it doesn't happen in the conversation with the thugs so I'm a little lost here. With all these little problems I don't know if this mod is worth it, but you let me know.
  8. 1 point
    Anyone else find themselves really missing the only LucasForums days? Feeling super nostalgic thinking of those days right now. Good times. Good friends.
  9. 1 point
    Yeah I remember being able to open the door on the xbox, but if I remember there wasn't much going on in there. I'm wondering if there's more hidden in the module relating to this. Anyway, great mod. It's always frustrating not being able to open a door, because you know the content is missing.