Sith Holocron

Bugs / Errors Reporting with M4-78EP

20 posts in this topic

Here's the place to report bugs, errors with other mods, etc when using M4-78 EP.
(If you wish to leave a comment about the M4-78 EP that doesn't concern bugs or errors, leave those on the Impressions thread here.)
While there are currently no plans to update M4-78EP any further, if any game breaking bugs are found they obviously will be fixed (and maybe other tiny ones with them), if at all possible. So please don't assume it's automatically a useless thing to report stuff here.

NOTE: Only report issues here if you use the latest version of M4-78!  If you don't have version 1.5, please update to the latest version of the M4-78 Enhancement Project as that very well might resolve your issue. (Read the current version's read me to see if that may be the case.)

When reporting bugs . . . use the following format and include both the questions and the answers to them.

1) During the game, when did the problem begin to occur? (List a general description of the issue.)

2) Did you install the latest version of the mod? (We are only covering issues concerning version 1.3 - the latest edition.)

3) What version of the game do you have? (Steam, GOG, 4CD, or the KotOR Collection?) What region is the game designed for if it's the 4 CD version?

4) Did you update your game as required by your game's region? (Update is required for 4-CD version only. If using a Steam, KOTOR Collection, or GOG version, put down "N/A")

5) Did you use the TSLPatcher, if provided?

6) Were there any errors in the TSLPatcher installation?

7) What other mods have you installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

8 ) Can you be more specific about the error? At what point did it happen? (List a detailed description of the issue.)

9) Have you tried re-downloading the mod?

10) Have you tried using a different save game?

11) Have you tried starting a new game?

12) What Operating System do you use? (List Virtual Machines as well if you are using them.) If you're a Mac user, please note that here as well.

Update: Here are a few extra questions to include as well. All posts (after the one following this one) should include all 16 questions and your answers to them.

13) Can you confirm that you see the TSLRCM logo on the the main menu screen?

14) What language is your game set for?

15) Which language of TSLRCM are you using?

16) Are you playing this on a laptop or a desktop computer?

Share this post


Link to post
Share on other sites

1) During the game, when did the problem begin to occur? (List a general description of the issue.)

 

Issue seems to be related to Sithspecter's TSL High Quality Blasters mod.  I'm on my first playthrough with that mod and no issues until I reached M4-78.  Issue is all the repeating blaster rifles carried by the  battle droids on M4-78 are without skins, just solid black or white models.  If I craft a repeating blaster rifle at the workbench and equip it, it has the high quality skin.  It is just the battle droid weapons.  I have previously played through M4-78 1.3 and didn't notice this issue.

 

I only installed the blasters mod in the TSLRCM workshop folder, it won't install in the M4-78 folder (installer says dialog.tlk not found).  I have not tried installing the blasters mod in the game folder, I'm reluctant to do that in case it breaks something, I don't want to have to wipe and reinstall everything just for this.

2) Did you install the latest version of the mod? (We are only covering issues concerning version 1.3 - the latest edition.)

 

Yes.

3) What version of the game do you have? (Steam, GOG, 4CD, or the KotOR Collection?) What region is the game designed for if it's the 4 CD version?

 

Steam.

4) Did you update your game as required by your game's region? (Update is required for 4-CD version only. If using a Steam, KOTOR Collection, or GOG version, put down "N/A")

 

N/A.

5) Did you use the TSLPatcher, if provided?

 

N/A.

6) Were there any errors in the TSLPatcher installation?

 

N/A.

7) What other mods have you installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

 

Steam workshop - TSLRCM, M4-78 and workbench crystal attunement B.

 

Others - Deadman's cyber swords and quarterstaff mods, Vao armband drop, Sith troopers to assassins.

 

I have used all these for a while without any issues (including a playthrough with M4-78 1.3).

 

The two new mods I am using are:-

 

High quality blasters - http://deadlystream.com/forum/files/file/915-high-quality-blasters/

 

Armoured robes -   http://deadlystream.com/forum/files/file/246-armored-robes-for-jal-shey-armors/ 

8) Can you be more specific about the error? At what point did it happen? (List a detailed description of the issue.)

 

On encountering battle droids on M4-78.

9) Have you tried re-downloading the mod?

 

N/A.

10) Have you tried using a different save game?

 

Went back to save in Ebon Hawk immediately after landing on M4-78.  Issue still there.

11) Have you tried starting a new game?

 

Not for something this minor.  I will look out to see if this occurs with the M4-78 droids on Citadel station during the Sith attack.

12) What Operating System do you use? (List Virtual Machines as well if you are using them.) If you're a Mac user, please note that here as well.

 

Win 10 64 bit

Share this post


Link to post
Share on other sites

That is likely because the weapons are part of the droid models but use the same textures as the real weapons. It's been known to be the case before and likely is here as well.

Share this post


Link to post
Share on other sites

That is likely because the weapons are part of the droid models but use the same textures as the real weapons. It's been known to be the case before and likely is here as well.

 

Are the weapons used with the droid models all the default repeating blaster rifle?  I'm thinking that if so then copying the blaster mod files for that weapon into the M4-78 override may fix the issue.

Share this post


Link to post
Share on other sites

Even if they were, that wouldn't be a solution. The way the texture displays on the weapon is a part of the model itself. And the weapons in this case may be part of the droid models and not spawned in by the game when the weapon is equipped.

So the only way to fix that would be to edit the droid models themselves, which has its own issues. So this may be an issue you'll have to live with.

Share this post


Link to post
Share on other sites

According to the changelog for the K1 version of this mod, Sithspecter fixed a similar issue there with version 1.1. So it would most likely be possible for him to do the same here, but that's of course completely up to him to decide.

Share this post


Link to post
Share on other sites

According to the changelog for the K1 version of this mod, Sithspecter fixed a similar issue there with version 1.1. So it would most likely be possible for him to do the same here, but that's of course completely up to him to decide.

I have pointed this exchange out to SS in a PM. Hopefully, we'll hear something soon.

Share this post


Link to post
Share on other sites

I have looked at my PM and email history and cannot prove that I actually sent a message to SS as I stated. Though it's extremely late, I have now rectified that error.

Share this post


Link to post
Share on other sites

1) During the game, when did the problem begin to occur? (List a general description of the issue.)

-I'm stuck on the quest, Rebuild I1-01!

2) Did you install the latest version of the mod? (We are only covering issues concerning version 1.3 - the latest edition.)

-yes

3) What version of the game do you have? (Steam, GOG, 4CD, or the KotOR Collection?) What region is the game designed for if it's the 4 CD version?

-Steam

4) Did you update your game as required by your game's region? (Update is required for 4-CD version only. If using a Steam, KOTOR Collection, or GOG version, put down "N/A")

-yes

5) Did you use the TSLPatcher, if provided?

-N/A I used Steam workshop

6) Were there any errors in the TSLPatcher installation?

-N/A

7) What other mods have you installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

TSLRCM - https://steamcommunity.com/sharedfiles/filedetails/?id=485537937

Kotor Save Editor - https://steamcommunity.com/sharedfiles/filedetails/?id=487038719&searchtext=kse (I noticed the quests don't appear in the KSE when I open the save file so I can't fix them there)

8) Can you be more specific about the error? At what point did it happen? (List a detailed description of the issue.)

I am trying to get I1-01 rebuilt and can't find who to talk to in order to do it. The quest log says "You killed the droid in the Design department. Without him, you'll need to find another way to finish rebuilding I1-01. You can also ask the Industrial Zone's maintenance unit for help at any point."

I'm now stuck and can't figure out what to do in this step. If I ask the maintenance unit what to do, he just says to talk to IS-99. I killed both IS-84 and IS-99 and now have IS-84's head in my inventory that I don't know what to do with. I can't do anything on the computer at the R&D area. My situation is nearly identical to the one in this thread that didn't address the issue:

http://deadlystream.com/forum/topic/3250-is-99-glitch-cant-find-fix-blocking-progress/

However, in this thread they mention going to the shack for droid diagnostics and that his counterpart will be I1-02. The droid I found is still IS-02, but there's something strange about his voice. I don't know if that's related.

9) Have you tried re-downloading the mod?

-no, I'd rather ask first than risk messing something up.

10) Have you tried using a different save game?

-no my last save for this area was 3 hours ago, I'll attempt to upload my current one.000000 - QUICKSAVE.zip

11) Have you tried starting a new game?

-no

12) What Operating System do you use? (List Virtual Machines as well if you are using them.) If you're a Mac user, please note that here as well.

-Windows 10

Update: Here are a few extra questions to include as well. All posts (after the one following this one) should include all 16 questions and your answers to them.

13) Can you confirm that you see the TSLRCM logo on the the main menu screen?

-yes

14) What language is your game set for?

-English

15) Which language of TSLRCM are you using?

-English

16) Are you playing this on a laptop or a desktop computer?

-desktop

Share this post


Link to post
Share on other sites

1. During the game, when did the problem begin to occur? (List a general description of the issue.)

This problem was evrytime I played the game.

2. Did you install the latest version of the mod? (We are only covering issues concerning version 1.3 - the latest edition.)

I know exactly that it is in 1.2, 1.3 and 1.5.

3. What version of the game do you have? (Steam, GOG, 4CD, or the KotOR Collection?) What region is the game designed for if it's the 4 CD version?

Steam (legacypc).

4. Did you update your game as required by your game's region? (Update is required for 4-CD version only. If using a Steam, KOTOR Collection, or GOG version, put down "N/A")
N/A.

5. Did you use the TSLPatcher, if provided?

N/A.

6.  Were there any errors in the TSLPatcher installation?

No.

7.  What other mods have you installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

Oh, it`s a long story, master. But I don`t think other mods can do it. I played with this mod and TSLRCM and had this bug.

:). Can you be more specific about the error? At what point did it happen? (List a detailed description of the issue.)

I5-65 and the droid with the same model in the Industrial zone have wrong shadows.

9. Have you tried re-downloading the mod?

Yes.

10.  Have you tried using a different save game?

Yes.

11.  Have you tried starting a new game?

Yes.

12.  What Operating System do you use? (List Virtual Machines as well if you are using them.) If you're a Mac user, please note that here as well.

I played the game on Windows xp and 8.1.

13. Can you confirm that you see the TSLRCM logo on the the main menu screen?

Yes.

14.  What language is your game set for?

English.

15.  Which language of TSLRCM are you using?

The same.

16. Are you playing this on a laptop or a desktop computer?

A desktop the 1st time and a laptop the 2nd.

20181107151903_1.jpg

Share this post


Link to post
Share on other sites

1) During the game, when did the problem begin to occur? (List a general description of the issue.)
A number of quest-related and cosmetic issues occurring after entering M4-78. Some of these have been reported in other threads here.
Saved Game (after all problems triggered): http://pa3pyx.dnsalias.org/stuff/m478ep_save1.7z

2) Did you install the latest version of the mod? (We are only covering issues concerning version 1.3 - the latest edition.)
Yes (version 1.5.1)

3) What version of the game do you have? (Steam, GOG, 4CD, or the KotOR Collection?) What region is the game designed for if it's the 4 CD version?
Steam (exe version 1.0.2 private build 427)

4) Did you update your game as required by your game's region? (Update is required for 4-CD version only. If using a Steam, KOTOR Collection, or GOG version, put down "N/A")
N/A

5) Did you use the TSLPatcher, if provided?
Yes (to install HQ graphics mod, merging appearance.2da) -- source below

6) Were there any errors in the TSLPatcher installation?
No

7) What other mods have you installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)
HQ graphics mod (based on Xenon's unofficial 1.0c patch). Uses only graphical components from the unofficial patch -- .mdl, .mdx, .tga, .txi overrides and appearance.2da changes to textures and envmaps, but no other files or changes (to avoid conflicts).
http://pa3pyx.dnsalias.org/stuff/tslrcm_hq_10c_20190104.7z
Extra mod is therefore very unlikely to cause the issues described.

😎 Can you be more specific about the error? At what point did it happen? (List a detailed description of the issue.)
How I got there:

Spoiler

i) After getting my party into the Central Zone, used Bao-Dur to take down the force field and barge into Environmental Zone;
ii) Chased Kaah all the way, destroying his guardian droids, let him go, and talked to ES-05 (asking her to reactivate M4-78);
iii) Proceeded to Industrial Zone, let Kaah open the door to Research section, solved the quests there to get access to IS-24 (opening the door to him);
iv) Solved the quests that would normally be end the lockdown in Industrial Zone (which may have already been ended).

8a) (Gameplay) The quest "Re-activate M4-78" is not completable if Environmental Zone is completed before Industrial Zone, but the player chooses *not* to skip the quests to get past the lockdowns in Industrial Zone.
(Saved game above can be used to examine variable state.) In my particular case Kaah opened the door to R&D section, then I solved both rebuilding I1-01 and CS-45 quests to get audience with IS-24. Moreover, this led to indefinitely repeated I1-02 commissioning scene in Manufacturing (any time the player revisits this area) and indefinitely gaining 1000 experience each time it plays.

8b) (Gameplay, minor) If the Environmental Zone is visited first (as above), ES-05 can be questioned about events that the player doesn't know about yet.
For example, the player can ask whether ES-05 destroyed I1-01, but the player doesn't have any quests related to I1-01 yet. (Though, arguably, player's droid may have already interrogated IS-02 about it.)

8c) (Gameplay, minor) If the Environmental Zone is visited first (as above), while returning from ES-05 to the Central Zone, the player comes across an area locked down, supposedly, on M4-78's orders.
However, M4-78 has not been activated yet.

8d) (Gameplay) The "Fixing Droids" quest is not completable because one of the parts required to repair the droid in Central Zone is missing.
"Main Droid Processing Unit" is nowhere to be found. According to walkthroughs, it was supposed to be in a junk heap in an outdoor storage area just before the entrance into the testing section of Industrial Zone, behind the line of inactive combat droids. However, in version 1.5 (where Industrial Zone was split into multiple areas) there is no longer a set of droids in this area, nor a junk heap behind them. Possibly I just overlooked the item and it's in a different place now, or I missed a quest reward at some point. But more likely this is a regression introduced in 1.5.

8e) (Gameplay) In the scene just before M4-78 room, one of the Sith Assassins remains alive, but friendly (?) after the attack scene.
(Load the attached savegame, then go down to M4-78 room.)

Spoiler

"I already handled Vash, don't want no puny Exile anymore".

8f) (Cosmetic) The L5-65 droid in the Central Zone (and any other droids sharing his model, such as Loading Droid in manufacturing) has "bleeding" in its shadow.
(See attached screenshot.) Screenshots made by other people confirm the problem. Probably the model needs some minor corrections.
image.png.d6a7622504c2ff9f2c6246ed674f86d6.png

8g) (Cosmetic) Before clearing the radiation in the Central Zone, the "pollution haze" fog is not applied consistently to all surfaces.
(See attached screenshot.) In particular, walls and floors don't show any fog at all, whereas most objects do (but not all). Also, skybox texture is missing in the Central Zone (but not in Industrial Zone) although the fog is present in both. If this is a game engine problem and cannot be fixed with content changes, it's probably better not to use the fog effect altogether (colorful exhaust from vents should be enough). After all, radiation is supposed to be invisible.

8h) (Cosmetic) In a number of places, the subtitle text shown does not match the voice-overs spoken.
One example is IS-24 where the player is directed to Environmental Zone (where he may have already been), another is CS-36 (confusing the first and second assistant Archons).

8i) (Cosmetic) Voice-over volume varies widely and is inconsistent with the rest of the game.
It's probably a good idea to use a program such as WaveGain or MP3Gain (in No-undo mode) to normalize the all voice-over volumes to a value consistent with the rest of the game.

9) Have you tried re-downloading the mod?
No

10) Have you tried using a different save game?
No

11) Have you tried starting a new game?
Yes (new game was started after installing all mods, with no other mods installed after)

12) What Operating System do you use? (List Virtual Machines as well if you are using them.) If you're a Mac user, please note that here as well.
Windows 7 Enterprise 64-bit, Intel HD Graphics 440 (driver version 10.18.14.4578)

13) Can you confirm that you see the TSLRCM logo on the the main menu screen?
Yes (version 1.8.5)

14) What language is your game set for?
English

15) Which language of TSLRCM are you using?
English

16) Are you playing this on a laptop or a desktop computer?
Laptop

Share this post


Link to post
Share on other sites
6 minutes ago, Pa3PyX said:

2) Did you install the latest version of the mod? (We are only covering issues concerning version 1.3 - the latest edition.)

Yes (version 1.5.1)

Oops!  It looks like I had to update that part (the highlighted portion).

Hopefully, the mod makers will get back to you in a reasonable amount of time.  If not, I suggest sending them a PM.

Share this post


Link to post
Share on other sites

Additional bugs discovered on the 2nd play-through (same set-up, but now done in "proper" order,  i.e. Industrial Zone before Environmental Zone):

8j) (Gameplay, minor) When the player's droid talks to IS-02, they are always teleported back to Central Zone, even if this is not their first conversation (and therefore if they already downloaded the code from Central console).
TBH, probably it's better to avoid teleporting the player back and forth; since it's the first exploration of the area, this only serves to confuse the player (let the player find their own way around the first time). It's only a small portion of the area that will be explored by the main character, anyway.

8k) (Gameplay, blocking) After filing an appropriate report in "Taking In the Trash" quest, the player witnesses two utility droids being destroyed; after the second droid, the image fades out and never fades back in (game is stuck, the only way to proceed is Alt+F4). However, if the player clicks through the animation (i.e. does not wait for explosion & fade-out), they properly regain control.

8l) (Cosmetic) "Damaged Construction Droid" that was "fixed" by a rogue employee is missing at least some of the voice-overs (no voice, no droid sounds).

8m) (Gameplay) "Deadly Upgrade" quest erroneously reappears and becomes not completable if you (1) have found the battle droid using the upgrade; (2) chose to run away and invite logistics droid to the scene; (3) recovered the upgrade part and kept it (completing the quest); (4) proceed past the Industrial Zone into the Testing zone. The quest starts to say that the logistics droid will be interested to know you recovered the part, but the droid only says a one-liner and refuses to talk anymore, rendering the quest stuck.
Probably a regression introduced by 1.5 due to the splitting of Industrial Zone. I have also seen other quests erroneously refresh when moving between these zones. Most likely caused by using local variables instead of global ones (now that the modules are separate).

8n) (Gameplay, blocking) In the Environment Zone, if the player talks to the Archon and then chooses to  use Escort Droid to depart into the Environmental Zone (instead of simply walking out), they are teleported right behind a group of construction droids traversing a locked-down area (where the mine field used to be). The player can follow the droids into the area (doors will unlock before the droids), but if the player fails to also follow the droids out (before the doors close behind them), they become stuck in the mine field area with no way out (the door on either side won't open, not even from the inside).

8o) (Gameplay) Escort droids fail to take the player to the Environmental Archon (ES-05) even after the player makes their way there and talks to her.

8p) (Gameplay) "Data Transfer" quest cannot be completed if the player talks to the rogue employee (and picks up the quest) before Kaah is dead.
If that happens, the player is supposed to either talk to Kaah when he gets the chance, or if Kaah is killed, let the "employee" decipher the data by himself. But Kaah has no dialogue options to discuss the matter (in either Environmental or Central zones), thus no way to advance the quest variable from 3 to 4 required, and therefore the only option the player gets with the "employee" is "We shall talk later". Even if Kaah eventually dies. Probably also a regression introduced in 1.5 as a result of ending alteration?

  • Like 1

Share this post


Link to post
Share on other sites

Did a comparative play-through of version 1.3, and confirmed that the above issues 8a, 8b, 8d, 8e, 8j, 8k, 8l, 8m, 8n, 8o, 8p are all regressions introduced in version 1.5 as a result of refactoring the Industrial Zone into 4 separate modules to improve the frame rate, and introducing a different ending. As for 8g, version 1.3 includes a separate shader patch to correct the problem.
In other words, most of the problems above (some of them quite serious, resulting in incompletable quests) are not present in version 1.3, therefore version 1.3 is the most stable version of the mod available today. It also has a more interesting and believable ending (IMO).

Since version 1.3 was never hosted on this site for political reasons, and it's not possible to download without buying the game on Steam, this leaves GOG and Retail game owners with either buggy 1.2, or buggy 1.5. For these users, I am hosting version 1.3 on my web site for the time being. Note that the shader patch component (opengl32.dll and the shaders_override folder) are intended for Steam version only and need not be installed for other versions.
http://pa3pyx.dnsalias.org/stuff/m478ep13.7z

  • Like 1
  • Light Side Points 1

Share this post


Link to post
Share on other sites

Fix your mod dudes. Pretty sad, when the shiny "new release" that you "cared" enough to make, is broken worse than previous versions.

Regarding political reasons: are we adults or not? This crap drives me nuts, and not swearing there was serious challenge.

  • Like 1

Share this post


Link to post
Share on other sites

P.S. I realize the authors at this point probably do not have enough time or inclination to actively develop or test the project. If so, it would be helpful if the mod was checked into source control somewhere (Github being the most obvious choice), so that any fixes or enhancements could be directly contributed by the community as pull requests.

  • Like 1

Share this post


Link to post
Share on other sites

Just a little note, folks.  Though I created this thread quite some time ago, I'm not part of the team.  I'm interested in what happens to the mod (I am posting in here, right?) but I have no real pull with "the team". 

In addition, neither Zbyl2 and Hassat Hunter are either subscribed to this thread or even this section.  You may have a faster response if you PM them or ... you might not.  YMMV.

Great feedback BTW, @Pa3PyX!

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Pa3PyX said:

P.S. I realize the authors at this point probably do not have enough time or inclination to actively develop or test the project. If so, it would be helpful if the mod was checked into source control somewhere (Github being the most obvious choice), so that any fixes or enhancements could be directly contributed by the community as pull requests.

@zbyl2, @Hassat Hunter

 

Fix your mod. Or revert to last functional build. Or give someone else the keys.

I feel happy and just fine telling these guys what to do with their mod. I was working on it with Stoney literally years before either of them touched it. They didn't have to release an update, but they did. Making it a piece of garbage that doesn't work is not ok; if nothing else they should get over their political idiocy and just upload the most stable recent version (1.8.3?) to DeadlyStream.

I'm sure you're both busy. So am I.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now