High Quality Skyboxes II 2.0

   (51 reviews)

70 Screenshots

About This File

Lnx50sb.png

ABOUT:

This mod replaces every skybox and every planetary backdrop in the game with a new high resolution version made from scratch.
This includes a replacement of every skybox model to fix all the glaring issues with the original.
There are also some additional minor changes that either fix issues with the vanilla environments or serve to better blend ingame terrain and skybox.
Other than that I recommend you just check out the screenshots as pictures say more than a thousand words :) or check the video to see the animated skyboxes.

Click the following image to see additional interactive screenshot comparisons:

dZ7kOn9.jpg

There are also add-ons with new skyboxes for the following mods:

If you find any issues or have any other comments, please let me know and I'll see what can be done.

 

INSTALLATION:

If you have a previous version of this mod installed, remove it before installing the new version or you might run into some issues.

For installation instructions check the read-me files of the individual downloads. Usually it's just copying files to your Override folder. For the mod to take full effect you need a savegame where you have not yet left Dantooine.

 

COMPABILITY:

This mod is not compatible with any mod that edits skyboxes in any way. This includes mods that only edit their models. There might also be rare incompabilities with mods that edit non-skybox area models if those models are also edited by this mod.

 

PERMISSIONS:

You may NOT redistribute any textures included in this archive without my explicit permission. You may however use all the models as long as you give me credit.

 

CREDITS:

This mod was created by Kexikus using mainly Terragen 4, Photoshop CS6 and 3ds Max as well as some After Effects. Additional tools used:

Additional resources by:

  • Andy Welder: Dantooine tree model
  • Animum: Yavin tree model
  • Bioware: Taris buildings, Kashyyyk buildings, Kashyyyk tree textures, Manaan building textures, Hammerhead cruiser model, Yavin ruins
  • dandelO: grass shader Dantooine and Yavin, snow shader Dantooine
  • Jeronimoe: BOS:SR Taris ship models
  • Jorak Uln: Taris window texture
  • killst4r: Unknown World palm tree
  • Martin Frank: Yavin bush model
  • Misha Winkler: Grass model Dantooine and Yavin
  • Quanon: Additional Taris buildings, Unknown World crashed ship
  • rhcreations: Yavin temple
  • Riccardo Faidutti (SCIFI 3D): Additional Taris buildings
  • Solarsystem Scope: Moon textures Dantooine, Unknown World and Ord Mandell, Yavin texture
  • Tom Patterson: Yavin cloud texture
  • Veronica Bush: Yavin bush model
  • Yughues: Kashyyyk branch texture
  • Unknown: Unknown World fern model

THIS MOD IS NOT SUPPORTED BY LUCASARTS OR BIOWARE. USE THIS FILE AT YOUR OWN RISK. NEITHER THE AUTHOR OF THIS MOD NOR THE COMPANIES MENTIONED ABOVE ARE RESPONSIBLE FOR ANY DAMAGE TO YOUR COMPUTER WHEN USING THIS FILE.


What's New in Version 2.0   See changelog

Released

Full rework of the entire mod  

  • Like 4



User Feedback

Recommended Comments



Hey @Kexikus , great job !!! I’m having a graphical glitch on Taris’ skybox but only on uppercity south . The building tops in the background are cut off. I will send an image when I get the chance . 

Share this comment


Link to comment
Share on other sites

Here’s the glitch and it’s upper city north, not south my bad . 

64720938-DB18-47F6-866C-1E1626C30D80.jpeg

Yes it’s a asus laptop model x555D with a Radeon A10 6th generation graphics . 

Share this comment


Link to comment
Share on other sites

Well, I would guess that this is somehow related to using a laptop GPU. Kotor is known to have issues with those. I have no idea how that would happen though, especially in only a single area.

You could check that the m02ab_sky and m02ab_01l models are in your Override. There should be .mdl and .mdx files for both of those. Maybe they got corrupted somehow but I doubt it.

Share this comment


Link to comment
Share on other sites

It could just be a mod conflict but I’m not sure. I’m not using any other mods that edit the skyboxes . I’ll check it out and let you know !! 

3 hours ago, Kexikus said:

Well, I would guess that this is somehow related to using a laptop GPU. Kotor is known to have issues with those. I have no idea how that would happen though, especially in only a single area.

You could check that the m02ab_sky and m02ab_01l models are in your Override. There should be .mdl and .mdx files for both of those. Maybe they got corrupted somehow but I doubt it.

Well interestingly there is a m02ab_sky with both mdl and mdx files,  but theres no m02ab_01 in my override . Maybe that's the problem, I'll try re-install. If that doesn't work, I'll empty my override and reinstall a clean game with less mods and see if that works . Thanks @DarthParametric and @Kexikus for your responses .

Share this comment


Link to comment
Share on other sites
1 hour ago, mackmitchell94 said:

It could just be a mod conflict but I’m not sure. I’m not using any other mods that edit the skyboxes . I’ll check it out and let you know !! 

Well interestingly there is a m02ab_sky with both mdl and mdx files,  but theres no m02ab_01 in my override . Maybe that's the problem, I'll try re-install. If that doesn't work, I'll empty my override and reinstall a clean game with less mods and see if that works . Thanks @DarthParametric and @Kexikus for your responses .

Sorry, I mistyped the second model. It should be m02ab_02l

  • Like 1

Share this comment


Link to comment
Share on other sites
3 hours ago, Kexikus said:

Well, I would guess that this is somehow related to using a laptop GPU. Kotor is known to have issues with those. I have no idea how that would happen though, especially in only a single area.

You could check that the m02ab_sky and m02ab_01l models are in your Override. There should be .mdl and .mdx files for both of those. Maybe they got corrupted somehow but I doubt it.

I reinstalled  but I’m still having the same issue . I have both those files but it must be one of the mods I’m using . I had a similar problem with taris on your previous version of HQ Skyboxes for K1 . You gave me an extra file and it worked when I utilized anti aliasing.  The mods I’m using are : Green grass for dantooine, Yavin IV, pc response, HQ nebulas and stars, Improved Grenades, K1 extremely realistic visuals, Taris dueling arena enhancement, and Better male face 04. Any ideas ? 

38 minutes ago, Kexikus said:

Sorry, I mistyped the second model. It should 

Share this comment


Link to comment
Share on other sites
7 hours ago, Kexikus said:

Well, I would guess that this is somehow related to using a laptop GPU. Kotor is known to have issues with those.

It has an issue with integrated Intel GPUs (laptop or otherwise), but this is a slightly different case. Aside from being AMD, it actually uses a weird setup. Rather than use one half-decent GPU, they actually use two crappy GPUs in CrossFire (AMD's equivalent of SLI). It doesn't even used a matched pair, it uses two different ones, one better than the other. I assume because at the time they didn't have a half-decent mid-range mobile GPU available, so they had to cobble together what they could from available low end parts.

I assume that CrossFire is probably disabled for KOTOR, since it would require a driver profile for it to work and that is unlikely to exist. The question is which GPU it is running on. You should check the driver control panel and maybe the BIOS to see if you can manually disable the individual GPUs. If that is possible, try running it on both separately to see if you get the same issue after switching.

  • Like 1

Share this comment


Link to comment
Share on other sites
8 hours ago, mackmitchell94 said:

I reinstalled  but I’m still having the same issue . I have both those files but it must be one of the mods I’m using . I had a similar problem with taris on your previous version of HQ Skyboxes for K1 . You gave me an extra file and it worked when I utilized anti aliasing.  The mods I’m using are : Green grass for dantooine, Yavin IV, pc response, HQ nebulas and stars, Improved Grenades, K1 extremely realistic visuals, Taris dueling arena enhancement, and Better male face 04. Any ideas ? 

The only one that could be causing that is K1 extremely realistic visuals. Could you check if apart from LTS_bsky01.tpc which should be in your Override, there's also LTS_bsky01.tga or .txi? If so delete those and see if it helps. I doubt it because it works in the other modules but you never know.

  • Like 1

Share this comment


Link to comment
Share on other sites
33 minutes ago, Kexikus said:

The only one that could be causing that is K1 extremely realistic visuals. Could you check if apart from LTS_bsky01.tpc which should be in your Override, there's also LTS_bsky01.tga or .txi? If so delete those and see if it helps. I doubt it because it works in the other modules but you never know.

I’ll let you know how it goes . 

Share this comment


Link to comment
Share on other sites
16 hours ago, Kexikus said:

The only one that could be causing that is K1 extremely realistic visuals. Could you check if apart from LTS_bsky01.tpc which should be in your Override, there's also LTS_bsky01.tga or .txi? If so delete those and see if it helps. I doubt it because it works in the other modules but you never know.

 

20 hours ago, DarthParametric said:

It has an issue with integrated Intel GPUs (laptop or otherwise), but this is a slightly different case. Aside from being AMD, it actually uses a weird setup. Rather than use one half-decent GPU, they actually use two crappy GPUs in CrossFire (AMD's equivalent of SLI). It doesn't even used a matched pair, it uses two different ones, one better than the other. I assume because at the time they didn't have a half-decent mid-range mobile GPU available, so they had to cobble together what they could from available low end parts.

I assume that CrossFire is probably disabled for KOTOR, since it would require a driver profile for it to work and that is unlikely to exist. The question is which GPU it is running on. You should check the driver control panel and maybe the BIOS to see if you can manually disable the individual GPUs. If that is possible, try running it on both separately to see if you get the same issue after switching.

I looked for a LTS_bsky01.tga or .txi in override and there is no file by that name, only the tpc. It's also not K1 Extremely realistic effects because I tested again after reinstalling and didn't download that mod, only the skyboxes and HQ star and nebulas so I think Parametrics right on this. It has to be something with my GPU, unless there's another file I could delete . Last night I wondered if it could just be caused by needing to update my drivers but I have the AMD A10 8700p radeon R6 drivers with 10 computer cores, and apparantly they dont have any more updates for those on the AMD website. I'll try to do what Parametric suggests and manually disable the GPUS if I can .... Thank you guys for your help!!!

I don’t know guys, I tried to to switch GPUS in bios but it might just be unfixable. It’s like I’m missing a file or something since some of the buildings are cut off . Do you need frame buffer enabled ? I have anti aliasing and anistrophy enabled but disabling them seem to make no difference . It’s fine for upper city south ... I wonder why that is . I’ll continue trying to make it work, but I just wanna say great job @Kexikus. Even if I don’t get it working properly It’s still gorgeous !! 

EDE81DCB-547F-4C46-AEC7-E8292FB8D1F4.jpeg

78CF9DEB-3EF2-4415-97B4-40A15B0338C3.jpeg

E14B52F9-09F9-48F2-B3A5-32C24A5B8987.jpeg

Share this comment


Link to comment
Share on other sites

The problem you've got is overlapping transparencies. The engine is not able to get your GPU to render them correctly. This is likely a legacy problem stretching back to the game's launch, where it was known to have problems with then ATI GPUs. It also stretches to various other rendering issues across all GPUs for various things, but those are less noticeable for most people. Aside from installing the DX redistributable if you haven't already, I'm not sure there's much more you can do on your end.

The only practical permanent/universal solution would be for @Kexikus to replace that background alpha'd plane with actual cutouts of the buildings so that there is no alpha masking is required.

  • Like 1

Share this comment


Link to comment
Share on other sites

So I actually figured it out. I had to download Glooverride, also known as the grass fix. Now everything appears as it’s supposed to !! Wow thanks for this beauty of a mod @Kexikus

29350ACF-197A-4D64-838A-17B08C709039.jpeg

Share this comment


Link to comment
Share on other sites

Very cool.  I always had this in my override.  Nice to see an update.  66 files to over 200 now.  I love it.  Sadly notifications aren't showing up for new mods posted but glad I noticed this got an update to it.  Thank you.

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.