15 Screenshots

About This File

DEFAULT REPLACEMENT HILTS MEGAPACK 8.1
--------------------------------------------------------------------------
by Kaidon Jorn

 


This mod will replace the default lightsaber hilt models in KotOR 2:The Sith Lords.
Should be compatible with TSLRCM 1.8.4 and beyond.
This version omits the animated blade textures from the main mod but they are still offered as an option (copy and pate tga's and txi's into Override and let overwrite if necessary).
It also comes with a new(er) model for the cyan double-bladed hilt, and alot of the icons have been remade. Other than that, I changed every hilt texture's name and hex edited them into the original models. Also, this mod is now set to replace file on every installation. This should be the last one I need to do, but you never know.

 

-KJ

 

Permissions: You may not redistribute files contained herein and you may not use these files in your own mod without my consent.


What's New in Version 8.1   See changelog

Released

  • All color crystals have a unique hilt model.



User Feedback

Recommended Comments



I think the hilts are too big and clunky-looking but otherwise they're good. How do I uninstall this mod? I've tried to put the backup files into the Override but they don't seem to be working for some reason. The modded sabers are still present. 

Share this comment


Link to comment
Share on other sites

I tried putting this mod last and tried overwriting everything and it doesnt wokr. i erased the game and did it again and nothing. :(   im play it on STEAM and have the lastest TSLRCM.

Share this comment


Link to comment
Share on other sites

The latest game update messed up the textures for the hilts so it's just all chrome colored with no detail, anyone know how to fix this?

Share this comment


Link to comment
Share on other sites

Go to your SWKotOR II installation directory, open your "swkotor2.ini" scroll down to to the [Graphic Options] search for and find "DisableVertexBufferObjects=1" now; simply put spaces between each word so it looks like this "Disable Vertex Buffer Objects=1" If the line isn't there, just add it under [Graphic Options] at the end.

 

Unfortunately I tried this and it crashes the game, it works but I'm still trying to find a solution to fix the texture problem without the game crashing. I don't think it's the mod itself causing the issue, since before I installed this mod it was still having the textures problem even with the default hilts...So I think there was a game update at some point that screwed textures up at some point and no one has been able to find a decent fix for it. Damn shame because this is a great mod.

Share this comment


Link to comment
Share on other sites

Go to your SWKotOR II installation directory, open your "swkotor2.ini" scroll down to to the [Graphic Options] search for and find "DisableVertexBufferObjects=1" now; simply put spaces between each word so it looks like this "Disable Vertex Buffer Objects=1" If the line isn't there, just add it under [Graphic Options] at the end.

 

Unfortunately I tried this and it crashes the game, it works but I'm still trying to find a solution to fix the texture problem without the game crashing. I don't think it's the mod itself causing the issue, since before I installed this mod it was still having the textures problem even with the default hilts...So I think there was a game update at some point that screwed textures up at some point and no one has been able to find a decent fix for it. Damn shame because this is a great mod.

Yep so I guess just dont use any lighsaber replacement mods for the time being, it is a real bummer but it is what it is.

Share this comment


Link to comment
Share on other sites

Is there any option to get this hilt mods to work without turning off the vertex buffer? cause disabling this messes up with the char-mod I use.

Share this comment


Link to comment
Share on other sites
Is there any option to get this hilt mods to work without turning off the vertex buffer? cause disabling this messes up with the char-mod I use.
what character you use im curious

Share this comment


Link to comment
Share on other sites

Wow all hilts are chrome! Great job definitely deserve 4 and a half stars for it...😪

Edited by TheRealBatuRem
  • Dark Side Points 1

Share this comment


Link to comment
Share on other sites

Is Cyan and bronze being the default hilt model intentional? Cyan and Bronze are the only two colors that didn't change the hilt both have files to change the hilt but it isn't changing it in game. Double blade for cyan works just single bladed that doesn't.

Edited by DRAGONSLAYA90

Share this comment


Link to comment
Share on other sites

After a bit of testing, it looks as though the orange/bronze single bladed lightsabers are bugged. Both the orange and bronze single bladed lightsaber are using the same blade texture 'w_lsabrebrnz01'. The orange single bladed lightsaber should be using the 'w_lsabregold01' texture while the bronze should use 'w_lsabrebrnz01'. This issue does not effect the orange/bronze short lightsaber or orange/bronze double bladed lightsaber, which both use the correct blade textures.

I tested this by changing the name of another blade texture (e.g. 'w_lsabreblue01') to 'w_lsabrebrnz01' and checking if the blade colour produced by the bronze crystal had changed. Both the Bronze & Orange single bladed lightsaber blades i had equipped had changed colour, confirming that they both use the same bronze blade texture. However, i also noticed that both lightsabers appear to be using the Orange hilt with the Bronze blade. Upon checking the texture used by both models in MDLOps, it appears that the models 'w_lghtsbr_007.mdl' (Orange lightsaber) and 'w_lghtsbr_011.mdl' (Bronze lightsaber) have the correct textures assigned, so I'm not sure what the issue is.

Edit: So to resolve this, I'm using the older bronze lightsaber model and hilt texture from Kaidon Jorn's earlier "Default Replacement Hilts Megapack 6.0" mod (found here). I copied the  'w_lghtsbr_011.mdl' 'w_Lghtsbr_011.mdx' and 'w_lghtsbr_001.tga' (the older hilt model uses this texture for the hilt) from Jorn's 6.0 version of this mod, and placed it in my Override foler. Considering the issue initally appeared to be with the Orange lightsaber using the incorrect blade texture, it would seem that the issue was actually (somehow) with the bronze lightsaber. I'm not sure why, but changing the model of the bronze lightsaber to an earlier model does work, and also causes the orange lightsaber to use the correct blade texture. Both the bronze and orange lightsabers are using the correct model and blade textures now.

  • Like 1

Share this comment


Link to comment
Share on other sites

I was able to manually install this on the new IOS version of KOTOR 2.  The new hilts look great!  I have noticed a small bug that removes the shaders off the hilt making them look pure chrome in color.  This is not permanent and changes if you move the character to a darker area in the environment.

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.