PartySwap and Extended Enclave Compatibility Patch 1.6a

   (0 reviews)

2 Screenshots

About This File

=PartySwap and Extended Enclave Compatibility Patch=

A KNIGHTS OF THE OLD REPUBLIC II: THE SITH LORDS MODIFICATION

 


AUTHOR: Leilukin
FILE NAME: PartySwap_EEnclave_ComPatch.zip
LATEST VERSION: 1.6a
CONTACT: E-mail to leilukin[at]gmail[dot]com, or message to Leilukin on Deadly Stream

 

1) DESCRIPTION:

This patch will make the PartySwap mod by DarthTyren compatible with the Extended Enclave mod by danil-ch and Darth Hayze.

You can find and download the two mods here:
PartySwap: http://deadlystream.com/files/file/544-partyswap/
Extended Enclave: http://deadlystream.com/files/file/428-extended-enclave-tslrcm-add-on/

NOTE:

  • This patch may NOT be compatible with non-English versions of KotOR 2 and The Sith Lords Restored Content Mod (TSLRCM).
  • You do not need this patch if you want to use my Handmaiden and Female Exile - Disciple and Male Exile Romance mod, because my mod already includes compatibility patches that will allow my mod to work together with both PartySwap and Extended Enclave.

 

2) INSTALLATION:

STEP 1: Download and install The Sith Lords Restored Content Mod (TSLRCM), since TSLRCM is REQUIRED for both PartySwap and Extended Enclave to work. I recommend using the installer version of TSLRCM (https://www.moddb.com/mods/the-sith-lords-restored-content-mod-tslrcm/downloads) instead of the Steam Workshop version even if you play KotOR 2 on Steam.

STEP 2: Download and install PartySwap (You can find the mod here: http://deadlystream.com/files/file/544-partyswap/)

STEP 3: Download and install Extended Enclave (You can find the mod here: http://deadlystream.com/files/file/428-extended-enclave-tslrcm-add-on/)

(You must install Extended Enclave AFTER PartySwap)

STEP 4: Download my compatibility patch for PartySwp and Extended Enclave, extract PartySwap_EEnclave_ComPatch.zip to anywhere you like, as long as it is not within the KoOR 2 directory.

STEP 5: Run the PS EE Comp Patch Installer.exe from my compatibility patch. You will see there are two installtion options, and you may only select one of them:

  • No M4-78EP installed: Choose this installation option if you do NOT have M4-78 Enhancement Project installed.
  • M4-78EP installed: Choose this installation option if you DO have M4-78 Enhancement Project installed.

Once you have selected an installation option, point the installer to your KotOR 2 directory and let the installer do its magic.

 

3) UNINSTALLATION:

Go to the "backup" folder created by the TSLPatcher, cut and paste 650DAN.mod, 020EBO.mod and 904MAL.mod into the Modules folder in your KotOR 2 directory.

NOTE: This step is for uninstalling this compatibility patch only. This will not uninstall the Party Swap and Extended Enclave mods.

 

4) KNOWN ISSUES:

None currently known. If you find any bugs or problems, please let me know.

 

5) CREDITS:

DarthTyren and danil-ch for giving me permission to make this compatibility patch for their mods
Fred Tetra for the KotOR Tool
tk102 for DLG Editor
Stoffe for TSLPatcher

 

 

THIS MODIFICATION IS NOT SUPPORTED BY BIOWARE/OBSIDIAN ENTERTAINMENT OR LUCASARTS OR ANY LICENSERS/SPONSORS OF THE MENTIONED COMPANIES. USE THIS FILE AT YOUR OWN RISK AND NEITHER THE ABOVE MENTIONED COMPANIES NOR THE AUTHOR IS RESPONSIBLE FOR ANY DAMAGE CAUSED TO YOUR COMPUTER FOR THE USAGE OF THIS FILE.


What's New in Version 1.6a   See changelog

Released

  • Fixed an issue with the patch installation.
  • Like 1



User Feedback

Recommended Comments

The mod causes problems with the last diallog of Kreia on Malachor, when she is revealing the future of your companions. Can you fix it?

Share this comment


Link to comment
Share on other sites
31 minutes ago, Guibaesa said:

The mod causes problems with the last diallog of Kreia on Malachor, when she is revealing the future of your companions. Can you fix it?

Please be specific about exactly what kind of problems you encountered so I can at least try to figure out the cause of your problems how to fix it.

Also, did you install any other mods in addition to TSLRCM, PartySwap, Extended Encalve and this patch?

Share this comment


Link to comment
Share on other sites
7 minutes ago, Leilukin said:

Please be specific about exactly what kind of problems you encountered so I can at least try to figure out the cause of your problems how to fix it.

Also, did you install any other mods in addition to TSLRCM, PartySwap, Extended Encalve and this patch?

When kreia is revealing the future of your friends. When you reach the part of Disciple and Handmaiden you can only pick one. Letter the dialogue gets stuck when Kreia is supposed to die.

I managed to create a fix for it, Im posting it here.

904kreia.dlg

Share this comment


Link to comment
Share on other sites
22 minutes ago, Guibaesa said:

When kreia is revealing the future of your friends. When you reach the part of Disciple and Handmaiden you can only pick one. Letter the dialogue gets stuck when Kreia is supposed to die.

I managed to create a fix for it, Im posting it here.

904kreia.dlg

Thanks for the fix. The patch has been updated.

  • Like 1

Share this comment


Link to comment
Share on other sites
On 12/21/2018 at 11:00 AM, src888 said:

FYI... PartySwap & Extended Enclave were recently updated , might want to take a look

Thanks for the info. I had been incredibly busy recently so I just found out that both mods had been updated.

I have updated my patch. The latest change to PartySwap (Disciple's endgame dialogue with Carth/Cede) does not affect this patch at all, but my patch should now be compatible with version 2.4 of Extended Enclave.

Share this comment


Link to comment
Share on other sites

Alright, I just finished checking up the newest update. I have two bugs I would like to report:

1: When you are playing as a FEMALE character on the enclave, Briana uses the dialogue line: "Did you not go to join HIM?"

2: Once you arrive at the final boss fight and start talking with Kreia, she does not turn around to talk to you. Same thing happens in the middle dialogue (The one she asks you to kill her).

Can you please fix this issues?

Share this comment


Link to comment
Share on other sites

I just finished a LS Female playthrough, and I can confirm that this mod works with the 1.5 version of M4-78, at least as a LS Female character. Dark Side, Male and Easter Egg endings might be a different story but other than M4-78 and Extended Enclave both using the same cut dialog, there weren't any issues whatsoever.

Share this comment


Link to comment
Share on other sites

Just installed all the recent updates. Got 1 warning after installing this patch. Not sure if this is an issue or not. This is also a fresh install of the game.

installlog.txt

Share this comment


Link to comment
Share on other sites
3 hours ago, SetJudgment said:

Just installed all the recent updates. Got 1 warning after installing this patch. Not sure if this is an issue or not. This is also a fresh install of the game.

installlog.txt 1.89 kB · 2 downloads

The only issue you might encounter is an audio-related issue with the final Ebon Hawk cutscene between Kreia and Disciple when you play a female PC, but there is also a possibility that there won't be any issue. Regardless, I just re-uploaded the patch to fix the error.

Share this comment


Link to comment
Share on other sites

Got a warning, it was kredisc3.dlg or something. Hopefully it won't be game breaking, I don't mind any silly little bugs.

Thanks for the mod :)

Share this comment


Link to comment
Share on other sites
On 5/13/2020 at 5:19 PM, Kreia4life said:

Got a warning, it was kredisc3.dlg or something.

What exactly was the error message you got? Please open the installlog.txt file and paste it here. Sharing the exact error message you got would help modders identify the problem.

Did you install version 1.6a, which is the latest version of the patch? What are the mods you have installed? I have tested installing TSLRCM, PartySwap, Extended Enclave and the latest version of this patch and I did not get any errors during installation.

Share this comment


Link to comment
Share on other sites

I just installed the 1.6a patch, and received one error and one warning. Tried reinstalling with compatibility settings, and got the same result. Got the error code "Modules\020EBO.mod" does not exist at the specified location. Only have TSLRCM, M4-78, PartySwap, Extended Enclave, and a few retextured mods installed. Will this have any affect?

installlog.txt

Share this comment


Link to comment
Share on other sites
4 hours ago, CamronBaugh said:

I just installed the 1.6a patch, and received one error and one warning. Tried reinstalling with compatibility settings, and got the same result. Got the error code "Modules\020EBO.mod" does not exist at the specified location. Only have TSLRCM, M4-78, PartySwap, Extended Enclave, and a few retextured mods installed. Will this have any affect?

020EBO.mod is a module file that was created by Extended Enclave. The error should not happen if you have properly installed Extended Enclave, so if you got such error, there must be something wrong with your installation of Extended Enclave.

If you have installed both TSLRCM and M4-78EP, when you install EE, you actually need to run the EE installer twice to install both "TSLRCM Standalone" and "M4-78 Compatibility patch" components. Since you got the error that 020EBO.mod did not exist, I am guessing you only run the installer once to install the "M4-78 Compatibility patch" component only. Is that correct?

The installation instruction has stated that "If you DO have the M4-78 installed, after running the TSLRCM Standalone installer, run the M4-78 Compatibility patch and follow the instructions presented to you." Read the mod author's instructions carefully when you install mods.

To fix your issue, I suggest you reinstall the whole game and the mods you want to use again, make sure you run the Extended Enclave installer twice, and then my patch, and see if you get the error again.

Share this comment


Link to comment
Share on other sites
On 7/12/2020 at 4:10 PM, Leilukin said:

020EBO.mod is a module file that was created by Extended Enclave. The error should not happen if you have properly installed Extended Enclave, so if you got such error, there must be something wrong with your installation of Extended Enclave.

If you have installed both TSLRCM and M4-78EP, when you install EE, you actually need to run the EE installer twice to install both "TSLRCM Standalone" and "M4-78 Compatibility patch" components. Since you got the error that 020EBO.mod did not exist, I am guessing you only run the installer once to install the "M4-78 Compatibility patch" component only. Is that correct?

The installation instruction has stated that "If you DO have the M4-78 installed, after running the TSLRCM Standalone installer, run the M4-78 Compatibility patch and follow the instructions presented to you." Read the mod author's instructions carefully when you install mods.

To fix your issue, I suggest you reinstall the whole game and the mods you want to use again, make sure you run the Extended Enclave installer twice, and then my patch, and see if you get the error again.

Thank you for the info, I did overlook that part unfortunately. Appreciate the quick reply though, and I will try to be better haha

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.