N-DReW25

Kotor Tool won't work

Recommended Posts

So I'm not 100% sure if this belongs here but every time I launch Kotor Tool I am greeted with an error saying

 

"We've attempted to detect your KotOR installation, but please verify the directories are correct."

 

Then after that Path Manager opens and in the kotor root path it has: C:\Program Files (x86)\Steam\steamapps\common\swkotor   Which is my normal root path so I can't change it because that is the correct path

 

Then after that a message saying

 

"Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

 

Could not find file 'C:\chitin.key'."

 

Then when Kotor Tool actually opens its Just blank no options nothing except for the options on the top so does anyone knows what happened and how to fix this.

 

Share this post


Link to post
Share on other sites

For non-CD versions, set your location via registry keys. Copy and past the relevant version below into a text file, and change the extension from TXT to REG. Double-click it and answer yes when it asks you if you want to add it to the registry.

 

For 64bit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BioWare\SW\KOTOR]
"Path"="X:\\YOUR_DIR\\HERE"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LucasArts\KotOR2]
"Path"="X:\\YOUR_DIR\\HERE"
For 32bit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\BioWare\SW\KOTOR]
"Path"="X:\\YOUR_DIR\\HERE"

[HKEY_LOCAL_MACHINE\SOFTWARE\LucasArts\KotOR2]
"Path"="X:\\YOUR_DIR\\HERE"
  • Thanks 1

Share this post


Link to post
Share on other sites

For non-CD versions, set your location via registry keys. Copy and past the relevant version below into a text file, and change the extension from TXT to REG. Double-click it and answer yes when it asks you if you want to add it to the registry.

 

Ok so were do I place the REG folder 

Share this post


Link to post
Share on other sites

Create a new text file anywhere. On your desktop for example. Copy and paste either the 32bit or 64bit version of the text above, depending on what version your OS is. Change the path info to whatever your local K1/TSL install directories are (note that you must use double slashes, not single). Save the text file and close it. Change the file extension of the text file from TXT to REG. Now double click on the REG file. A window will pop up asking if you want to add the information to the registry. Click yes. A confirmation window should say it was added successfully. That's it, you can now delete the REG file. Now older tools that use a registry lookup will be able to find your KOTOR install automatically. For KOTOR Tool you will want to delete the settings.xml file as Fair Strides suggested.

Share this post


Link to post
Share on other sites

 Change the path info to whatever your local K1/TSL install directories are (note that you must use double slashes, not single). Save the text file and close it.

Okay so by change path you mean change

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BioWare\SW\KOTOR]

Into my game path which is

C:\Program Files (x86)\Steam\steamapps\common\swkotor

So so I Just type

[C:\Program Files (x86)\Steam\steamapps\common\swkotor]

Share this post


Link to post
Share on other sites

No. The path value. Like this:

 

For 64bit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BioWare\SW\KOTOR]
"Path"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\swkotor"
For 32bit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\BioWare\SW\KOTOR]
"Path"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\swkotor"
You haven't mentioned TSL, so I assume you don't have it, or not the Steam version anyway.

Share this post


Link to post
Share on other sites

You haven't mentioned TSL, so I assume you don't have it, or not the Steam version anyway.

 

 

 

 

Oh I do  have TSL for steam but when Kotor tool worked it never worked so if I had to mod TSL I would have to change the k1 path and replace it with the TSL path so the k1 resource tree would be the TSL resource tree even though its in the place were k1 should be.

 

So I attempted it and like before it had no effect though i'm not 100% sure if I did it correctly

Share this post


Link to post
Share on other sites

Here, try this. You obviously have a 64bit version of Windows (indicated by the Program Files (x86) folder). I also added in TSL.

 

Make sure you delete the KT settings.xml file after adding the registry info. You may even want to try uninstalling KT and reinstalling it.

KOTOR_Registry_Keys_x64.zip

Share this post


Link to post
Share on other sites

The KOTOR tool is being a royal pain. 

 

I only have TSL installed,  had downloaded the reg files above in the thread.  ( I had deleted the KOTOR 1 registry parts,  as I do not have kotor installed.. )

 

When the KOTOR tool loads,  I follow through with the first run configuration.  I delete the kotor directory,  ( as the game is not installed, ) & KOTOR 2 is auto-detected in the proper directory.

 

The error I get is;

 

" Could not find file "C\chitin.key" ?  

 

I have tried copying the chitin.key file from the KOTOR 2 directory to the C:\ drive,  however I then get an error message:

 

"Chitin.key file not valid"

Your KOTOR 1 chitin.key file appears to be corrupt.

You may want to reinstall KOTOR II to fix this.

 

 

I had installed KOTOR 2 properly,  however I do not even have kotor 1 installed.   Had installed the appropriate Microsoft framework prior to installation.. 

 

Do I need to install kotor 1 just so that I can actually load the damned editor ?  LOL...

 

Thank you for your assistance.

Share this post


Link to post
Share on other sites

So I'm not 100% sure if this belongs here but every time I launch Kotor Tool I am greeted with an error saying

 

"We've attempted to detect your KotOR installation, but please verify the directories are correct."

 

Then after that Path Manager opens and in the kotor root path it has: C:\Program Files (x86)\Steam\steamapps\common\swkotor   Which is my normal root path so I can't change it because that is the correct path

 

Then after that a message saying

 

"Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

 

Could not find file 'C:\chitin.key'."

 

Then when Kotor Tool actually opens its Just blank no options nothing except for the options on the top so does anyone knows what happened and how to fix this.

Sorry for bringing this old topic back, but the same thing just happened to me yesterday night. I've  tried reinstalling the tool, but have had no luck. I'm using the US 4 CD version.

For non-CD versions, set your location via registry keys. Copy and past the relevant version below into a text file, and change the extension from TXT to REG. Double-click it and answer yes when it asks you if you want to add it to the registry.

 

For 64bit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BioWare\SW\KOTOR]
"Path"="X:\\YOUR_DIR\\HERE"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LucasArts\KotOR2]
"Path"="X:\\YOUR_DIR\\HERE"
For 32bit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\BioWare\SW\KOTOR]
"Path"="X:\\YOUR_DIR\\HERE"

[HKEY_LOCAL_MACHINE\SOFTWARE\LucasArts\KotOR2]
"Path"="X:\\YOUR_DIR\\HERE"

Would these registry key work the same for the 4 CD version (except for the location destination, which would obviously be changed)?

 

Might try deleting the settings.xml file in KotOR Tool's folder and re-opening it.

Should this be the first step in trying to troubleshoot this problem?

Share this post


Link to post
Share on other sites

Would these registry key work the same for the 4 CD version (except for the location destination, which would obviously be changed)?

Those keys are what the CD version already uses, hence why you need it for the other versions (seeing as they didn't exist when KTool was coded). There should be no need to use it for the CD version unless you have manually moved the install folder.

Share this post


Link to post
Share on other sites

Sorry for bringing this old topic back, but the same thing just happened to me yesterday night. I've  tried reinstalling the tool, but have had no luck. I'm using the US 4 CD version.

Would these registry key work the same for the 4 CD version (except for the location destination, which would obviously be changed)?

 

Should this be the first step in trying to troubleshoot this problem?

I ran Kotor tool in administrator mode and it worked again. Only downside was I now have a Windows 7 style border around Kotor Tool on a Windows 10 Computer, everything works though.

  • Like 1

Share this post


Link to post
Share on other sites

I ran Kotor tool in administrator mode and it worked again. Only downside was I now have a Windows 7 style border around Kotor Tool on a Windows 10 Computer, everything works though.

Okay, that did the trick. Do I have to run it as an admin from this point on then? Thanks for the assist. :)

Share this post


Link to post
Share on other sites

Okay, that did the trick. Do I have to run it as an admin from this point on then? Thanks for the assist. :D

I'm not sure whether I flipped some sort of option to make it run admin all the time or it runs admin all the time, sorry about that.

Share this post


Link to post
Share on other sites

^^^ You could also do that to a shortcut, if for some reason you wanted to be able to run KT not in Admin mode sometimes.

 

DPs suggestion is the simplest!

Share this post


Link to post
Share on other sites

If you are running it from a folder under Program Files then you will likely need to always run it as an admin. Right click on the exe, Properties, click Run as Administrator. That will enable it permanently.

 

^^^ You could also do that to a shortcut, if for some reason you wanted to be able to run KT not in Admin mode sometimes.

 

DPs suggestion is the simplest!

I had to mess around with the properties tab a bit, but I got it working to run as an admin. Thanks for your help! :)

Share this post


Link to post
Share on other sites
On 7/15/2016 at 4:34 AM, DarthParametric said:

For non-CD versions, set your location via registry keys. Copy and past the relevant version below into a text file, and change the extension from TXT to REG. Double-click it and answer yes when it asks you if you want to add it to the registry.

 

For 64bit:

 


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BioWare\SW\KOTOR]
"Path"="X:\\YOUR_DIR\\HERE"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LucasArts\KotOR2]
"Path"="X:\\YOUR_DIR\\HERE"

For 32bit:

 


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\BioWare\SW\KOTOR]
"Path"="X:\\YOUR_DIR\\HERE"

[HKEY_LOCAL_MACHINE\SOFTWARE\LucasArts\KotOR2]
"Path"="X:\\YOUR_DIR\\HERE"

This just saved me, Thanks for taking the time to explain this all those years ago :) Works like a charm with windows 10. 

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.