Recommended Posts

Just when I decided to switch to blender. You.Are.Awesome.

 

 

Edit: I just tried it. Is there a specific method of exporting  an area walkmesh? At the moment I have to change the  walkmesh from trimesh to aabb in notepad. Also is it possible to add an Other designation to the aurora base list? Sill KAurora recognizes it so I am extremely pleased (even more so after I upgraded neverblender and it messed up exports).

Share this post


Link to post
Share on other sites

Just when I decided to switch to blender. You.Are.Awesome.

 

 

Edit: I just tried it. Is there a specific method of exporting  an area walkmesh? At the moment I have to change the  walkmesh from trimesh to aabb in notepad. Also is it possible to add an Other designation to the aurora base list? Sill KAurora recognizes it so I am extremely pleased (even more so after I upgraded neverblender and it messed up exports).

 

 

 

That's one of the things I'm working on improving in KotORBlender right now, but really there is no specific method of exporting a area walkmesh, Hunters Run. Did you get a traceback call when you exported it out of Blender? If you did, I'd love to see that if you could copy it and post that here. Also, which Blender version are you using BTW?

Share this post


Link to post
Share on other sites

Hi Purifier,

 

I am having trouble to make it work with head meshes and Taina's Replacer. I was trying to replicate this tutorial using Blender, but the texture gets messed on the Head mesh when I change the UV Coordinates of some vertices. Doing the same using 3ds Max 2014 I have notice that when use Blender the Taina's replacer "Texture Coordinates" list changes, for example, the head was number 1 in the list and after exporting from Blender the head goes to 24 in the list, while using 3ds Max the number of the mesh in the list doesn't change. Do you think it is something that you can fix on KotORBlender?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi Purifier,

 

I am having trouble to make it work with head meshes and Taina's Replacer. I was trying to replicate this tutorial using Blender, but the texture gets messed on the Head mesh when I change the UV Coordinates of some vertices. Doing the same using 3ds Max 2014 I have notice that when use Blender the Taina's replacer "Texture Coordinates" list changes, for example, the head was number 1 in the list and after exporting from Blender the head goes to 24 in the list, while using 3ds Max the number of the mesh in the list doesn't change. Do you think it is something that you can fix on KotORBlender?

 

Thanks.

 

Long time no see, Kha. Glad to see you're still modding KotOR these days. I actually learned some things from you back in the early days over at LucasForums (merging bodies), when I was just a noob\ lurker modding KotOR. Good to see your still around and still at it.  ;)

 

 

Okay, I will look into this issue, while I'm currently in the process of upgrading KotORBlender's python code. So thanks for bringing it to my attention. I normally don't use Taina's Replacer concerning modding heads, I usually do hex editing after using MDLops. But I'll check the method of using Taina's Replacer out and get back to you ASAP, Kha. And see if it's something that can be fixed in KotORBlender.  :D

  • Like 1

Share this post


Link to post
Share on other sites

I have been playing with DAO and Skyrim, but now with your KotORBlender I am really tempted to remap the UVs of my old models and repaint its texture in Blender to fix all those awful visible seams. B)

Thanks for taking a look into this and see if Taina'a Replacer can be used with KotORBlender. Also, if I could ask for one more thing, it would be really great if KotORBlender could create an armature when importing the skinned mesh to make it easier for weight painting... I would never use 3ds Max again for modding Kotor!! :thumbsup:

Share this post


Link to post
Share on other sites

I have been playing with DAO and Skyrim, but now with your KotORBlender I am really tempted to remap the UVs of my old models and repaint its texture in Blender to fix all those awful visible seams. B)

 

Thanks for taking a look into this and see if Taina'a Replacer can be used with KotORBlender. Also, if I could ask for one more thing, it would be really great if KotORBlender could create an armature when importing the skinned mesh to make it easier for weight painting... I would never use 3ds Max again for modding Kotor!! :thumbsup:

 

I see. Well nothing wrong with improving one's old mods. Improvement is always good ;)

 

Funny you should mention that, "armatures", I've been working on that one too, so the user could test the rigging and character animation pose with using the bones; like in Gmax\3ds Max. So it's actually been in the "To-Do" works.  ;)

  • Like 1

Share this post


Link to post
Share on other sites

Hey, I’ve been wondering. Would it be possible to create a plugin that would automate converting an imported MakeHuman model to a format that KotORBlender could export?

Share this post


Link to post
Share on other sites
On 5/28/2018 at 3:26 AM, LiliArch said:

Hey, I’ve been wondering. Would it be possible to create a plugin that would automate converting an imported MakeHuman model to a format that KotORBlender could export?

Hey sorry for the delay reply, LiliArch. You know...I'm not sure. Tell you what though, let me ask someone who knows more then me about that and get back to you. :)

  • Haha 1

Share this post


Link to post
Share on other sites

I can send files, if that would help. (I have a 75-% complete KotOR rig for MakeHuman already, it’s the Blender part that’s giving me grief.)

Share this post


Link to post
Share on other sites

When I try to export a model to an .mdl, I get the attached error. How might I remedy this or is this user error? :P

kotorblender-error.png

Share this post


Link to post
Share on other sites

Uncheck 'Export TXI Files' on the Export Odyssey MDL settings and/or don't use relative paths, I believe. Probably one of those places I should look at making paths more OS-neutral, and also probably find /look for the Blender API relative path methods...

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, ndix UR said:

Uncheck 'Export TXI Files' on the Export Odyssey MDL settings and/or don't use relative paths, I believe. Probably one of those places I should look at making paths more OS-neutral, and also probably find /look for the Blender API relative path methods...

That did the trick, thanks fam.

Not to be a pain again... but once I exported an .mdl, it locks up when I try to Read/Write in MDLOps. Could be user error of course. :)

Share this post


Link to post
Share on other sites
2 hours ago, CarthOnasty said:

Not to be a pain again... but once I exported an .mdl, it locks up when I try to Read/Write in MDLOps. Could be user error of course. :)

What does it say in the black dos window when you do that?

Also are using any processed files that were edited and exported out of the old KB version(0.1), then imported into the new KB version(1.0) and then exported from the new version?

Share this post


Link to post
Share on other sites
7 minutes ago, Purifier said:

What does it say in the black dos window when you do that?

Also are using any processed files that were edited and exported out of the old KB version(0.1), then imported into the new KB version(1.0) and then exported from the new version?

Just says reading ascii model and freezes up.

And I've only used 1.0 with this model.

Share this post


Link to post
Share on other sites
6 minutes ago, CarthOnasty said:

Just says reading ascii model and freezes up.

And I've only used 1.0 with this model.

You mean it freezes like that for over a minute or two?

Share this post


Link to post
Share on other sites
1 minute ago, Purifier said:

You mean it freezes like that for over a minute or two?

Yeah, I went and had dinner and it was till like that. Tried a couple times, same thing.

Share this post


Link to post
Share on other sites
4 minutes ago, Purifier said:

Hang on, CarthOnasty. We're looking at the file. Might be a while before we get back to you. :)

Not a problem at all. Let me know if you need anything else.

  • Thanks 1

Share this post


Link to post
Share on other sites

MDLEdit compiles it with no errors but can confirm that MDLOps is choking on it. Loading it into KOTORMax causes the script to throw an error at line 2547, which is the end of node emitter Projectorflare.

 

Edit: A quick comparison to the vanilla indicates that the Blender version is missing "chunkname" and "render Motion_Blur" from that node. After replacing that node with a copy from the vanilla version, KOTORMax throws an error at the next emitter node, so presumably KOTORBlender needs a tuneup in that regard.

  • Thanks 1

Share this post


Link to post
Share on other sites
24 minutes ago, DarthParametric said:

MDLEdit compiles it with no errors but can confirm that MDLOps is choking on it. Loading it into KOTORMax causes the script to throw an error at line 2547, which is the end of node emitter Projectorflare.

 

Edit: A quick comparison to the vanilla indicates that the Blender version is missing "chunkname" and "render Motion_Blur" from that node. After replacing that node with a copy from the vanilla version, KOTORMax throws an error at the next emitter node, so presumably KOTORBlender needs a tuneup in that regard.

Yeah O' man, sucker is locking up bigtime! Apparently MDLOps 1.0.1 does not like this file. Lol. Thank you for pin-pointing that out, DP.  Appreciate it! ;)

Looks to be another bug to be fixed for the next KB version. Well anyway, we'll see what Ndix thinks when he takes a look at it.

Share this post


Link to post
Share on other sites

Interesting. If you compile and decompile with MDLEdit, you can see it adds in blank chunkname and render variables to each node. So I guess @bead-v added in a failsafe for missing variables, which is why it doesn't crash. Although presumably it would not function correctly in-game, given it is missing all the specific render semantics like Motion_Blur, Billboard_to_Local_Z, etc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.