Sign in to follow this  
Ginnet Reno

Kotor2 camera issues

Recommended Posts

So I installed and played through Kotor2 using the spoiler mod build listed on this site: https://kotor.neocities.org/modding/mod_builds/k1/full#4GB_Patcher.

Anyhow, it worked great for the most part except for one very irritating issue and that is that after some cutscenes would play my mouse would get stuck spinning my character in circles. I could fix it by saving, quitting, and reloading the game, but it was rather annoying to have this issue happen whenever I traveled to a new planet or saw a cutscene.

I did some googling around on it but never found a true fix for it that worked for me. I don't have the vjoy component in my pc that some claim is the culprit.

I'm curious if anybody else encountered this issue and if so were you able to fix it? I want to do another run of kotor2 and I'd love it if I could solve this issue. It doesn't kill the game for me but it is annoying lol.

Share this post


Link to post
Share on other sites
4 hours ago, Ginnet Reno said:

Anyhow, it worked great for the most part except for one very irritating issue and that is that after some cutscenes would play my mouse would get stuck spinning my character in circles.

It sounds to me like your mouse input got interrupted somehow, this definitely isn't an issue caused by the mod build.

Share this post


Link to post
Share on other sites
Posted (edited)
35 minutes ago, Thor110 said:

It sounds to me like your mouse input got interrupted somehow, this definitely isn't an issue caused by the mod build.

Well sorry I don't mean to imply that the mod build caused the issue. I think it's a kotor 2 issue somehow. It sounds like based on my googling that other users have encountered this issue and I don't think all of them were using modded builds. Unfortunately I haven't been able to track down a permanent fix that works for me. 

What's weird is saving and relaunching the game fixes it. So it's still playable with it, but obviously that gets annoying after a time. 

Edited by Ginnet Reno

Share this post


Link to post
Share on other sites
1 minute ago, Ginnet Reno said:

Well sorry I don't mean to imply that the mod build caused the issue. I think it's a kotor 2 issue somehow. It sounds like based on my googling that other users have encountered this issue and I don't think all of them were using modded builds. Unfortunately I haven't been able to track down a permanent fix that works for me. 

What's weird is saving and relaunching the game fixes it. So it's still playable with it, but obviously that gets annoying after a time. 

You should just be able to click back into the game, you could also try to pause and un-pause, ensuring that your mouse isn't off-screen to stop this from happening as it is caused when the mouse goes off screen, for example, are you playing in windowed mode or do you have multiple monitors?

5 hours ago, Ginnet Reno said:

Anyhow, it worked great for the most part except for one very irritating issue and that is that after some cutscenes would play my mouse would get stuck spinning my character in circles.

I don't know how to interpret that as anything other than implying that the mod build caused it.

Though going by the thread title I can see that you don't mention the mod build, so I am sure you can see why I thought as much. Nevermind.

Share this post


Link to post
Share on other sites
Posted (edited)
13 minutes ago, Thor110 said:

You should just be able to click back into the game, you could also try to pause and un-pause, ensuring that your mouse isn't off-screen to stop this from happening as it is caused when the mouse goes off screen, for example, are you playing in windowed mode or do you have multiple monitors?

I don't know how to interpret that as anything other than implying that the mod build caused it.

Though going by the thread title I can see that you don't mention the mod build, so I am sure you can see why I thought as much. Nevermind.

Nah you're fine I can see why the way I worded it would imply that.

I've tried positioning the mouse different ways before cutscenes but it doesn't seem to make a difference. I don't have multiple monitors setup. I have tried the game in both windowed mode and full screen in case that resolved the issue but neither made a difference. I also don't have any joysticks or controllers plugged in and have checked my managed devices to make sure nothing else is showing up there.

When the issue occurs nothing will fix it except for quitting and relaunching the game. Reloading won't fix it, nor will alt tabbing out/into the game or swapping to windowed mode/full screen. And it always occurs - always - after a cutscene.

The only other thing I could think of trying that I have not tried is disabling my Razer mouse software and just using the windows drivers and seeing if that changes anything. Maybe kotor 2 hates externally managed mouse software. I'd hate to have to do that every time I play though, and I guess I'd need to test it first to see if that even helps.

edit: tried quitting out of my Razer desktop managing software just to see if that made a difference but it did not. Same issue as before.

Weird.

Edited by Ginnet Reno

Share this post


Link to post
Share on other sites
29 minutes ago, Ginnet Reno said:

edit: tried quitting out of my Razer desktop managing software just to see if that made a difference but it did not. Same issue as before.

Could be worth trying a restart as well and not having it boot on startup, just to be sure as I have seen other people have similar problems caused by Razer hardware.

Is the mouse cursor visible on screen at all when this is happening? IE : can you see the green TSL cursor or has it just disappeared altogether?

Share this post


Link to post
Share on other sites
Posted (edited)
51 minutes ago, Thor110 said:

Could be worth trying a restart as well and not having it boot on startup, just to be sure as I have seen other people have similar problems caused by Razer hardware.

Is the mouse cursor visible on screen at all when this is happening? IE : can you see the green TSL cursor or has it just disappeared altogether?

 

37 minutes ago, DarthParametric said:

It's definitely not a mod issue. It's user peripheral input for sure. Might help to see the full contents of Device Manager to see what's plugged in.

Well, I feel very stupid right now. I had previously checked my device manager to see if any other devices were showing up there that shouldn't have been. Everything looked fine to me so I moved on.

I have a joystick on my desk that I thought was not plugged in as I have not played any games that use joysticks for a long time, so for the hell of it, I checked behind my pc and....lol. Of frickin' course it was plugged in. I unplugged it. Problem seems to be gone for now. I think the joystick was flagged as something generic like "USB Input Device" or "HID Compliant Device" in my device manager, so I assumed it was just a driver for something else.

I'm still very confused why this problem only occurred after cutscenes and I otherwise had no issues (would have thought the joystick would have interfered all the time), but I am willing to let that mystery lie for now lol.

Thanks for the help guys. This should make future playthroughs a lot smoother for me.

 

Edited by Ginnet Reno
  • Haha 1

Share this post


Link to post
Share on other sites

This should only be possible with the Aspyr version of TSL, since they added controller support to it. Won't/can't happen in the vanilla version or in K1. At least not without some emulation layer allowing controller input. So as with many other problems it introduces, your life would be easier rolling back to the "legacy pc" version in the betas branch drop-down. At least for future reference anyway. You don't want to do it mid-playthrough since it will nuke your current install.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this