Sign in to follow this  
JediArchivist

[WIP] Running Kotor I large mods (total conversions, story mods) on the IOS platform

Recommended Posts

This is a thread I made on LucasForums back in 2016, where I was experimenting with adapting larger mods to IOS. I am posting it here since it might help people, and I intend to continue my research!

 

This thread is to offer important feedback to modders and help adapt the larger Kotor I mods (such as Brotherhood of Shadow) on the IOS version of Kotor I.

Since I have replayed Kotor I as an IOS version, I totally loved the idea of porting and optimizing it for mobile platforms! If works great on an iPad, the big screen, portability and optimized controls made playing Kotor on IOS feel like reading a great book, it is an awesome experience!

After re-finishing the games on my iPad, i started looking for story mods and total conversions, wanting more of this awesome gaming experience. I discovered that small mods like appearance changers and added items can be easily installed, however larger mods that introduce new modules into the game do not seem to run properly, and there seems to be nobody working on getting them to work...

I tried the following story / total conversion mods so far, and managed to get them working to some degree, but so far they all seem to have major problems regarding how the scripts and asset placement are handled by the mobile port of the game:
1. Brotherhood of Shadow - Solomon's Revenge
2. Yavin IV Mod
3. Kotor 1 Restored Content Mod

Here is a detailed report I have made from a beta tester's standpoint regarding how these mods are handled by the IOS version.

1. Brotherhood of Shadow - Solomon's Revenge

Type: story mod / total conversion
Adds entire new modules to the game, with new areas, characters and items.

- Changed mod files filenames from uppercase or mixed characters to complete lowercase characters in order to fix the IOS character capitalization issue.

- Installed on a jail broken IOS device (iPad 3 Wi-Fi), transferred onto device via the iFunBox Windows application (was used to transfer the mod assets from the PC to the iPad), installed using the IOS Cydia app iFile (was used to place the mod assets into the game install directory because iFunBox had restricted access to that folder).
Mod installed successfully.

- Game runs fine after mod installed, the Brotherhood of Shadow splash screen appears after the Kotor 1 splash screen, just like on the PC version. Nothing changes when starting a new game or loading an older save game. If the save game included in the Brotherhood of shadow mod is also installed, along with the mod, loading it will not be possible! In order to make it work, we must change all the save games files filenames to complete lowercase letters because IOS has this issue, where case capitalization of filenames matters! A file named "Save.sav" will be seen as a distinct file from "SAVE.SAV", also distinct from "save.sav" - this is very important when attempting to run a mod!
Changed file names to complete lowercase, save game now loads.

- After loading save game, the game runs perfect, the player can go to Korriban and will notice new assets like the Czerka outpost and the technician fixing the door on the corridor! The player can start the mod's story-line by talking to the Rodian inside the bar. The characters are loaded perfectly, their appearances are the same as on PC, the conversation runs perfect, there are no bugs to this point.

- When the player lands on Tatooine to confront Daemon Drexl, the game runs OK until the player exits the spaceport and enters the city gate. At that moment, after the module loads, a few seconds after successfully loading and the player takes a few steps on the map, the game suddenly crashes! Tried multiple times, the same result occurs, the game exits back to IOS.
Bug occurrence: 5/5

- Using a PC i bypassed this point, transferred the save game file to a PC, played that section on the PC until the mission on the Orion begins (in order to bypass all Tatooine sequences, since the game crashes in this area). Transferred new save game made on the Orion back to iPad.
Save game loads, new BoS loading screens work perfectly on IOS!

- Started playing further on the Orion on the iPad, some module assets are completely missing! All the doors on the Orion are missing,through the ones that should be permanently closed outer space can be seen, plot related doors (like the cargo bay door) are also absent, allowing the player to enter those areas.
Sara Degana is also completely missing from the map, this bug is practically preventing the player to progress further in the game!
All other assets appear and work perfectly, the player can speak to the Captain, the Mechanic and the Pazaak player and the conversation works with no bugs, all other items work fine.

- Bypassing this portion of the game like before was not possible this time, as when the save game is transferred back to the PC some of the missing assets still do not appear! The doors now appeared as normal, but Sara Degana was still missing.
Continued with the old save (before moving it to the IOS), that loaded all assets, including Sara. Progressed further until back in the first section of Orion, where the player must find the code fragments in order to open the cargo bay to access the artifact. Transferred new save to the iPad.

- Doors and enemies that loaded perfectly on the PC using the same save game are now missing, the enemies do not show up, instead only the piles of items that show after they are defeated are present (it is like they had all been killed before loading the save).
Other assets like the robots work OK, the computer console can be accessed and the codes inputted. After all codes are inputted and the player gives the computer terminal the command to open the cargo bay door, the game crashes like on Tatooine.

After this portion I have stopped play-testing this mod on IOS. I have used a smart Windows application that allows multiple files renaming, to change all the file names of all files of the mod to lowercase letters (this was done to circumvent the IOS case letters capitalization roadblock that affected the save game files).
There was no result, everything runs just like before (that is strange since I had expected at least some reaction, as the renamed files should have either loaded because before they could not load before due to the uppercase filenames, either they could load fine before but changing their filenames to lowercase would have made them unloadable!)

Conclusions:
- The mod loads and runs to some extent, loading screen, environments, characters, items and conversations all load).
- Some certain assets (certain characters and environment entities, like doors) will not load.
- Game crashes at some points.
- Most issues seem to be cause by scripts (a given scripted event crashes the game) and assets (doors, characters that do not appear).
- Changing the entire mod content to lowercase files format will not habe any impact on the problem.
- Save games made after playing in a corrupted environment (first Orion module) will show most of the same corruptions when transferred on a PC where the mod runs perfectly (missing characters). However, some will not (no missing doors).
- It appears that entire module elements are sometimes stored onto the save game file (this has been observed by loading a save game done in a modded version of the game into an unmodded version of the game, where the modules that the save game takes place should be missing, yet the save-games load and the module can be explored!)
- Will attempt fresh reinstall using TSL Patcher method and post results soon!

2. Yavin IV Mod

Type: add-on story mod / total conversion
Adds new content (modules, characters, items).

- Mod installed via the same method as Brotherhood of Shadow (filenames renamed to lowercase characters and transferred via iFunBox). 

- Mod launches successfully when accessing the Yavin Space Station left door's control panel. There is a short conversation with the Rodian, then the Yavin mod modules load and work perfectly. Game runs normal in all aspects.

Conclusions:
- Mod can be successfully installed, started, and played! All the modules, scripts and assets work perfectly!
- Running Yavin IV mod on IOS KOTOR a complete success!
- Mod 100% play-tested, works perfectly on IOS!


3. Kotor I Restored Content Mod (K1 Restoration)


Type: add-on content mod / restored content mod
Adds new assets (modules, skins, items) that were cut / scrapped from the original game before launch, but partially left as inactive content in the game files.

- Installed using same method as for the previous two mods.

- Game loads normally, Kotor restoration splash screen (featuring the Iriaz) is displayed on startup. When starting a new game the first bug occurs: the skins for the male and female soldiers are corrupted, they show as black textures.

- The game runs smoothly afterwords, when crash landing on Taris the player can observe the new dialogue lines added by the mod. Everything loads and runs OK after, until reaching the Swoop Registration office at Lower Taris apartments (new location implemented by the mod in an abandoned apartment).
The area loads and works perfectly, but when entering the door to the Swoop Tracks the game freezes on the loading screen. The game is affected only if the player attempts to enter the door to the swoop tracks, otherwise you can exit the area and there are no other bugs.

- There are no problems until forward, when reaching the Black Vulkar base. When entering the elevator to the upper level (that has been added by the mod where the armory is located in the unmodded game), the game crashed after the loading screen. This was easily fixed by renaming the module, by changing all uppercase characters to lowercase characters!

- After renaming the filename the game loads the level without problems, and the Vulkar Base upper level added by the mid works well except for a few bugs. All assets and characters load and work OK, the player can speak to the Mechanic and the Vulkars in the bar, but the door to the control room where the player must update the garage key with the new code always remains locked, regardless of what the player does! This makes it impossible to progress further in the game.
The quest description for this level also have a bug, as they only appear as blank spaces with no text in the quest log!
After transferring the save game file to a PC and loading it from there (into a PC version of Kotor with the K1 Restoration mod installed), some parts of the quest logs appear and can be read, but the door still remains locked.

I have not yet played further, but plan to use a save game to bypass this area and test the mod on IOS further.

Conclusions:
- The mod runs mostly fine, with just a few bugs noticed so far (missing or corrupted textures, script errors).
- A major scripting bug causes the door on the Vulkar base upper level to always stay locked, preventing the player to progress further.

As I test the mods further I will keep updating the post.
If anyone else has been researching this and found any solutions to get these mods running on the IOS version, please post everything you have discovered (solutions, tutorials, fixed mod game files) here, it will be of great help!

 

Links to other threads that discuss Kotor I IOS modding:

http://www.lucasforums.com/showthrea...=212313&page=2
http://www.lucasforums.com/showthread.php?t=213381

It seems these are the only places on the entire internet where this has been discussed. There was also a brilliant blog called "Kotor IOS mods" made by the modder Revanchist, but it went offline since summer.

Users stated that they were working on adapting Brotherhood of Shadow for the IOS version and were close to solving all issues, but there was no reply on these threads since some time...if anyone managed to get it running please share your research and results with us!
Major kudos to anyone who managed to get BoS to run smoothly on IOS Kotor I!

 

Quote

Originally Posted by djh269 

So, is it possible to add mods to an iPhone for this game? But not jail-breaking it?

Cheers, 
djh269

 

Unfortunately there is no way to run mods on an non-jail-broken iDevice, because the mod files must be added to the contents of the KOTOR game folder on the iPhone / iPad using special file managers (iFunBox / WinScp and iFile).
On an non-jail-broken device the filesystem is locked, preventing users to access the core filesystem in order to add / modify the game files. On an un-jail-broken device the user only has access to the "Photos" folder from a PC / Mac, but in a limited read-only mode, and very limited acces is provided to other folders (Music, Video, Apps) via iTunes.
The jailbreak doesn't just add the Cydia app (as most people think), but it also unlocks the entire filesystem, enabling users to access the content on the iDevice like an external hard drive / USB stick by using the special file managers.

Th only thing that can be done on an non-jail-broken device is to modify save game files in order to add new items or change player stats.
This is done the following way:
1. Extract save game files from the iDevice to a PC / Mac using iTunes.
2. Edit the save game files with a KOTOR save game editor or hex editor if you are an experienced user.
3. Upload save game back to iDevice using iTunes.
Full detailed tutorial for editing KOTOR save game files can be found here:
https://www.reddit.com/r/kotor/comme...sion_of_kotor/

 

PROGRESS UPDATE

GREAT NEWS: I have managed to get Yavin IV mod to work flawlessly on the IOS version of KOTOR!

This has been fixed simply by deleting KOTOR from the iDevice, performing a clean reinstall, renaming all the mod files with their lowercase letter names equivalents on the PC before transferring them to the iDevice, then finally transferring the mod files to their proper folders inside the KOTOR app folder.
I have used a Windows application that renames multiple files at once, so I didn't have to rename each and every file manually, I just set the program to rename all the files and it processed them in less then a minute!
Also, the mod was not installed by the suggested way involving transferring the KOTOR app folder to a PC and using TSL Patcher on it, then transferring it back to the iDevice.
An easier approach was used:
1. The mod files were simply moved from the TSL Patch Data folder inside the mod installer to their proper folders (files that belonged to the "override" folder were placed in an "override" folder created for them (a new user created folder not the one in the game), the ones that go to the "modules" folder were placed in a "modules" folder, etc manually on the PC.
2. The files in these folders were then renamed to complete lowercase characters.
3. The contents of the folders were transferred to the folders with the same name in the KOTOR app folder in the iDevice (PC folder "modules" to "KOTOR.app/modules", etc).

For anyone that wants to get this mod, all the links on this forum are dead, and the mod is nowhere to be found unfortunately. This is the last working download link I have managed to find, and this is where I got the original mod files:
http://www.lonebullet.com/mods/downl...free-15640.htm

Now the mod launches properly when accessing the Yavin IV space station door, the level loads smoothly and all assets, items and cut-scenes load and work perfectly! I will keep "beta-testing" the entire mod content and post a detailed report with pictures soon.

Next step will be to try the same approach to the K1R (KOTOR I Restored Content) mod, where a high rate of success is expected, then tackle the biggest mod: Brotherhood of Shadow: Solomon's Revenge!

 

Quote

Originally Posted by Fair Strides 2 

If you didn't use the TSLPatcher, then you're manually installing...

I can guarantee that this will cause problems with K1R and BoS:SR... The files in the tslpatchdata folder are the unmodified versions of the files used by the mod, so things like the journal and the .2da files will be the same as if they were pulled from the game's files.

In the event that you use BoS:SR's manual install setup, you'd also be replacing the journal and any .2da files you already have, thus rendering those other mods inoperable while BoS:SR would itself work (maybe).

Thank You very much for this advice, this might actually solve the problem with BoS:SR! Actually I was recently thinking about researching this possibility, as I noticed that when installing the mod on a PC with TSLPatcher it reports that the .2da files are modified and not replaced. Your helpful comment just confirmed this theory!

This aslo explains why there were so many missing assets (doors, characters, etc) in my BoS:SR install attempt.

Installing all these three mods (K1R, BoS:SR and Yavin IV) together seems to be unproductive regardless the installation method used (TSLPatcher or manual install) and the platform the game is running on (Windows or IOS). I have tried running them together and there are game crashing bugs both on the PC and iDevice. It is stated by its creators though that K1R is compatible with BoS:SR, with the condition that K1R is installed last.
Since they bring independent story elements and it is not mandatory that they run at the same time, I have used a simple solution to get a complete KOTOR experience:
1. Install KOTOR and mod with K1R, play the enhanced original story campaign.
IMPORTANT: Keep a save game prior to traveling to the Star Forge (Rakata Planet)! This will be needed in order to play the other mods. If not, the save game included with the BoS:SR archive can be used.
2. Uninstall and perform a clean reinstall of KOTOR (mandatory on an IOS device, on a PC the KOTOR game folder can be backed up before installing the K1R mod and the un-modded copy can be used afterwards). Install either the Yavin IV or the BoS:SR mod on this clean install and enjoy! I chose to play Yavin IV first as BoS:SR brings an entirely new story line.
3. Repeat step 2 and mod the clean install with the other remaining mod.

I will install BoS:SR on my iPad with the TSLPatcher method ASAP and see if I can get it working properly.
 

Quote

Originally Posted by HK-42 

Great work, man. There aren't many people around this forum anymore, but I assure you we all appreciate the work!

Thank You and I am happy I could help this great community!

Remember when the mobile version of KOTOR was released in 2013 and people started modding it... After we got the simple mods (added skins, items, etc) to work and begun tackling larger mods (total conversions, story mods) like these ones that introduce entire new modules, everyone said that it is not possible to accomplish because the mobile version uses a re-scripted engine, that it will not work, etc.
We just believed that it could be done and kept trying anyway, and now we demonstrated that installing larger mods is actually possible and quite simple once we figure out how to do it properly. 

Yavin IV running smoothly is an example of this accomplishment, as it adds entire new modules containing new maps, skins, items, dialogue and cut-scenes, proving that the mobile version of KOTOR can handle this new game data quite fine.

The next milestone will be when the mobile version of KOTO II TSL will be released, as Aspyr Media completed the Mac OS port in July and are already working on the mobile port. If I were to make an educated guess I'd say that KOTOR II will probably be released for mobile platforms (IOS and Android) this Holiday season (most likely the middle of December), as this is a great time for Star Wars releases, because Disney is rebooting the franchise with the new movie and Battlefront 3 game, which will put Star Wars into the spotlight in this period.
Also, based on the fact that KOTOR II has almost the same game engine and structure as Kotor I (that has already been ported), and KOTOR II already has a Mac OS port, and is is known that IOS is actually a modified version of Mac OS, Aspyr just has to integrate the same touchscreen user interface and control scheme that was used in the first mobile KOTOR version, and optimize the game for the graphical and processing limitations of the mobile devices. This is something that a team of skilled developers can do in less than a month, with the remaining five months being more then enough for beta testing and tweaks, given that they already have experience in this field after doing this with KOTOR 1, and they also have access to the full KOTOR source code and developer SDK.

At any rate, I am sure there will be a mobile KOTOR II TSL release in the near future
http://www.aspyr.com/games/star-wars...the-sith-lords

When this will happen, most KOTOR veterans like myself will want to replay this gaming masterpiece, and obviously we will want to play it with TSLRCM installed!
Modders will then concentrate all their efforts to make TSLRCM to work with the mobile version, which will open the way for bigger story mods and total conversions, like The Jedi Masters and the brilliant work in progress Revenge of Revan!
Looks like a bright future... I can't wait to play these great mods in my iPad!

-------------------------

PROGRESS UPDATE - 07.01.2016

During the winter holidays I have finally managed to install Brotherhood of Shadow: Solomon's Revenge on the IOS version of Kotor, on my iPad, using the TSL patcher method.
I have used the method described below. I have written this tutorial to help anyone else who is uncertain about how to exactly install mods on IOS using the TSL Patcher, since there are many steps that must be carefully respected, although the process itself is not very complicated.

Brotherhood of Shadow: Solomon's Revenge (this method works with any mod) IOS Kotor mod install - TSL Patcher method:

A jailbroken iDevice is required!
1. Extract and backup the IOS Kotor app data with iFunBox.
Connect your jail-broken iDevice (on which Kotor is installed) to your PC / MAC computer. iFunBox must be installed on the computer.
Open iFunBox and go to the File Browser tab. Navigate to Raw File System/private/var/mobile/Containers/Bundle/Application and drag Kotor.app from the iFunBox window (it will also have the Kotor icon logo) and drop it to your Desktop. after the transfer is complete you will have a serialized filename folder on your Desktop. Congratulations, you have just backed up your Kotor install! If you also want to backup your Kotor user data which contains your game configuration and save games use iFunBox to navigate to Raw File System/private/var/mobile/Containers/Bundle/Application and (that's the tricky part) open all serialized filename folders/Documents until you find a KOTOR folder inside. Drag the entire serialised filname folder containing the KOTOR folder to your Desktop. Now you have backed up your game data as well!
It is wise to save the unmodified backup folders on your computer in order to ease up future modding (you can use a fresh copy of the backup each time you install a mod instead of extracting the Kotor game files from the iDevice each time)!
2. Copy the contents of the KOTOR.app folder inside the first serialized filename folder you extracted earlier (it will be the larger one) to a new folder (you can name it Kotor-mod)
3. Make sure that all the files inside Kotor-mod are NOT read-only. To do that select all files inside the folder, then right click and choose Properties, and check if the "Read-Only" tab is checked. If it is checked or greyed out, make sure to uncheck it!
4. Run the Brotherhood of Shadow: Solomon's Revenge TSL Patcher installer from the BoS:SR mod folder as an Administrator (right click on BoS: SR TSL Patcher installer and click on "Run as Administrator). IMPORTANT: if you have also Kotor installed on the computer you are performing this operation, rename the C:/Program Files/Lucas Arts folder (or whatever folder you installed kotor to) to C:/Program Files/Lucas Arts 001, so that TSL Patcher will not install BoS:SR to your PC / MAC Kotor installation!
Inside TSL Patcher, click Install Mod in the lower right corner of the window, then a Browse window will appear, prompting you to poimt it to your Kotor install folder (if you have Kotor also installed on your PC / MAC and do not temporarily rename the install folder as instructed earlier, TSL Patcher will detect it and automatically install the mod there!). Point it to your Kotor-mod folder where you copied the contents of the backed up KOTOR.app folder earlier.
Wait for the process to finish, you will most likely receive an error, do not worry it is caused by the fact that there is no "saves" folder inside the Kotor-mod folder, there is no problem, the mod files were copied regardless!
5. Run Multiple Files Renamer and set it to Capitalise / Add action / All small on the selected folders. In the selection screen open the Kotor-mod folder name select the modules, movies, override, streamsounds and streammusic folders.
This is very important, as your iDevice uses the Unix filenaming and hierarchy. This is also why you must make sure the files do not come set to read-only mode after extraction from the device. This is basically the roadblock preventing modders to run larger mods like BoS:SR on IOS, the IOS detects all files using a case-sensitive approach, like in the case for a password. Because of this, "BoSSR.mod" is seen as an entirely different file as "bossr.mod" or "BOSSR.MOD" by the IOS filesystem, thus resulting in a "file not found" error if the file is not properly renamed.
Congratulations, BoS:SR has been properly installed and adapted to your IOS Kotor installation!
6. Transfer the contents of the Kotor-mod folder back to their place on the iDevice usong iFunBox. Just navigate to the Kotor.app folder and drag the contents there.

Unfortunately even after using this recommended install method, the mod still won't run properly on IOS! I have double-chcked everything and the mod files were successfully copied into the Kotor install folder, I have no idea what goes wrong. Even more strange, the mod runs worse after being installed with the TSL Patcher method then it did after being installed with the manual method!

Here is the comparative beta-testing report:

- BoS: SR successfully installed (all files copied with no errors) using TSL Patcher method.
- When starting Kotor, instead of cycling through the intro splash screens, the screen stays black for 2-3 seconds then the game jumps right to the main menu. When using the manual install all splash screens appeared, including the custom BoS: SR splash screen added by the mod.
- The game runs normal prior to activating the mod. The Rodian is present in the cantina on Korriban, the player can interact with him in order to start the mod. Both the appearance of the Rodian and the dialogue are OK, no bugs so far.
- When arriving on Tatooine, right after leaving the spaceport and entering the city where the cantina is located, after the loading screen, the game freezes after the player takes a few steps forward or after 1-2 seconds. The same thing happened on when the mod was installed using the manual method. This error only occurs when Daemon Drexl must be confronted on Tatooine! Before activating the mod or when loading a save game file (taken from a PC) further into the game the game no longer crashes at this point. It seems that the entire module that contains the Daemon Drexl sequence on Tatooine gets corrupted by his script, causing the game to crash shortly after the module is loaded.
- A save game from a PC, taken after speaking to the Rodian on Korriban for the second time was used to bypass this crash. The Tatooine module now works perfect, the game does not crash anymore. The player can go into the cantina on Tatooine and talk to the Bith Captain of the Orion to start the mission. The dialogue works normal and then the intro movie for the mod begins (the one that starts with "Silveredge9 presents..." Showing the Orion fly through space). After the movie ends the game crashes. The crash did not occur when the mod was installed using the manual method.
- Used another save game file taken on the PC further into the game, aboard the Orion. After the save game loading screen the game crashes every time, like the module was missing or corrupted! When the mod was installed using the manual method, the module would load every time, but with some missing assets (doors, enemies, some of the characters). Now the game just crashes immediately after the save game loading screen. I have re-checked with iFile, and the module files for the mod are installed and in their proper folders...

Conclusions:
The mod is still not working, the game crash on Tatooine still takes place, and now all the mod's modules seem to be corrupt, as loading into them causes the game to crash immediately.
The following approaches will be attempted further:
- Will try capitalizing the filenames of all the files inside the "tslpatchdata" folder of the mod to complete lowercase BEFORE running TSL patcher.
- Maybe the modules do not load because when modding with TSL Patcher their default filenames get written into the modded .2da files. Since IOS is case-sensitive with all filenames, maybe the files point to a module called "Module1_BoS.mod", and because the module is now named "module1_bos.mod" the game can't find the file and thus crashes. I will try reinstalling with TSL Patcher but leaving the files as they are after, without renaming them to complete lowercase characters.

I will soon post updates on how these proposed solutions worked!


UPDATE 18.03.2016

Next I will try installing Vader's Elite's port of Bos:SR for Android on IOS, see how that works! It is already optimized for Android, and IOS has the same Unix root as Android does, so it might just work...

Edited by Sith Holocron
*Numerous* spelling errors throughout.
  • Light Side Points 1

Share this post


Link to post
Share on other sites

This is the conclusions I have come to after my long research, with some of the mods I tried:

 

KOTOR I Mod Compatibility

 

IOS:

KOTOR 1 Remastered (K1R) - Does not work, crashes the game at the Black Vulkar base lower level and it prevents Jolee from joining the player's party.

Brotherhood of Shadow: Solomon's Revenge (BoS:SR) - Does not work, crashes the game when launching, incomplete loading of levels.

Yavin IV Planet Mod - Works perfectly, no issues with it!

Lehon Mandalorian Expansion - Crashes the game when launching.

Enhanced Bastila Romance - Works perfectly, no issues with it!

Effixian's Mira Outfit for Bastila / Effixian's Mira as Bastila - Crashes the game.

Effixian's Female Underwear alternative K1 - Crashes the game.

Twin Suns outfit for Bastila - Crashes the game

 

ANDROID:

KOTOR 1 Remastered (K1R) - Did not test, I believe it should work fine.

Brotherhood of Shadow: Solomon's Revenge (BoS:SR) - Works perfectly, crashes on some levels if tablet / phone has less than 2 GB of RAM memory!

Yavin IV Planet Mod - Did not test, I believe it should work fine.

Lehon Mandalorian Expansion - Works perfectly, no issues with it!

 

I'll update this post once I test out the respective mods on Android as well.

  • Light Side Points 1

Share this post


Link to post
Share on other sites

I installed K1 Restoration mod, BoSSR and Yavin IV using the provided installers and the game starts fine on the latest iOS. However the K1R mod causes some textures to be completely black, like for example the default scoundrel outfit and the outfit of the guy who appears at the first moment when you start a game. Haven't played past that moment though. Any ideas what causes this texture problem?

  • Thanks 1

Share this post


Link to post
Share on other sites
On 9 aprilie 2021 at 12:53 AM, the_g said:

I installed K1 Restoration mod, BoSSR and Yavin IV using the provided installers and the game starts fine on the latest iOS. However the K1R mod causes some textures to be completely black, like for example the default scoundrel outfit and the outfit of the guy who appears at the first moment when you start a game. Haven't played past that moment though. Any ideas what causes this texture problem?

I have no idea why the black textures occur, it must be because K1R overrides the default texture. I remember having the same problem when experimenting with the mod on my old iPad 3.

Share this post


Link to post
Share on other sites

Now I'm well into the game, one planet left, and I played only with the BoSSR mod installed, as all other mods were causing these kinds of texture glitches. I tried installing each of them and starting a new game and it proved to be the only one that causes no glitches (I also tried the community patch fix).

However I still haven't gotten to start playing the mod itself... so let's see. I hope it will work!

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Finally got to start the BoSSR mod. The rodian that gives the first task also has no textures (all black) and once i enter the town on tatooine the game crashes and exits. so seems like the mod is not playable : /

Edited by the_g
  • Thanks 1

Share this post


Link to post
Share on other sites

BoS:SR in not playable on IOS, but works fine on Android. I have no idea why it won't work with IOS...

Strangely, the Yavin IV mod works flawlessly on IOS.

Share this post


Link to post
Share on other sites

For me the Yavin IV didn't work. Or at least it caused the same missing texture issues already on the character creation screen. So I didn't try playing it further. Not sure why it would work for you but not for me... weird

  • Thanks 1

Share this post


Link to post
Share on other sites
On 27 aprilie 2021 at 12:00 AM, the_g said:

For me the Yavin IV didn't work. Or at least it caused the same missing texture issues already on the character creation screen. So I didn't try playing it further. Not sure why it would work for you but not for me... weird

Did You rename all the mod's filenames to lowercase only?

If not, that might be the issue for your missing textures, because IOS is case sensitive, and does not "see" the textures because they have uppercase characters in their filenames!

Batch renaming all the files can be easily done using a Windows tool like MultiFileRenamer or Bulk Rename Utility.

https://sourceforge.net/projects/multifilerename/

I succesfully used MultiFileRenamer to get Yavin IV to work and the other mods to work partially.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this