Sign in to follow this  
Mellowtron11

Weird Graphical Limitations/glitches

14 posts in this topic

So my Windows 10 laptop works fine and old computer games like KOTOR2 run pretty well. However, when I started playing on this computer a couple years ago, the Sith Assassins lack the see-thru shimmering effect that's usually seen, instead getting a yellow white sheen around them when they enter stealth mode. Similarly, the watery shimmering edges of the screen are absent during Kreia's telepathic communications and the droids lack their blue or red monochrome first person view filter. However, the force sight effect works fine for me.

 

My computer has a Nvidia Geforce 940M graphics card that gets regular driver updates (current driver version 388.00), an Intel® I7 Core 5500 CPU @2.40GHz, and 7.9 GB RAM. One would think that there's enough power to cover all the graphical effects. Anyone know what might have caused this? I still play the game regardless, but this still made me curious.

 

post-30428-0-95167500-1509078104_thumb.png

post-30428-0-23178200-1509078168_thumb.png

post-30428-0-42099500-1509078190_thumb.png

post-30428-0-48189100-1509078712_thumb.png

Share this post


Link to post
Share on other sites

Mods? Something seems to be affecting your CM_baremetal.

I did turn up the brightness a little bit. The original lighting for the screenshots was really dark initially. Are you talking about the regular metal textures?

 

I also am using NDreW-25's K1 T3-M4 mod, so that's why T3 is so shiny.

Share this post


Link to post
Share on other sites

I am talking about the original textures. A mod may have replaced the default CM_Baremetal texture. It has happened before :)

 

Otherwise, it is indeed odd.

Share this post


Link to post
Share on other sites

I had the same thing. Open up your NVidia control panel and make sure that the default graphics processor is set to the NVidia one and NOT the integrated one. I think you can also change this by right clicking on your game exe, and selecting "Run with graphics processor" and choosing the NVidia one. Should fix it.

Share this post


Link to post
Share on other sites

I am talking about the original textures. A mod may have replaced the default CM_Baremetal texture. It has happened before :D

 

Otherwise, it is indeed odd.

Strange, the only mods I have running on TSL are as Follows:

 

TSLRCM 1.8.5

K1 T3-M4

TSL NPC Stat Fixes Mod 1.0

PMHC05 by Darth Moeller

 

I have no graphical overhauls of any kind.

Share this post


Link to post
Share on other sites

I had the same thing. Open up your NVidia control panel and make sure that the default graphics processor is set to the NVidia one and NOT the integrated one. I think you can also change this by right clicking on your game exe, and selecting "Run with graphics processor" and choosing the NVidia one. Should fix it.

When doing this and going into the program settings of the 'Manage 3D Settings' part of the control panel, I choose to customize the SWKotOR2.exe and then select the Nvidia processor, right? Thanks for the info so far!

Share this post


Link to post
Share on other sites

When doing this and going into the program settings of the 'Manage 3D Settings' part of the control panel, I choose to customize the SWKotOR2.exe and then select the Nvidia processor, right? Thanks for the info so far!

 

Yes, that should get it going. I'm not 100% sure on all the details because your system and graphics card is different than mine, but I hope that will restore those graphical features for you.

Share this post


Link to post
Share on other sites

Yes, that should get it going. I'm not 100% sure on all the details because your system and graphics card is different than mine, but I hope that will restore those graphical features for you.

I just adjusted everything in the control panel and am still getting the same result. Any other ideas?

Share this post


Link to post
Share on other sites

Are you guys sure? I always thought those kind of effects were controlled by the frame buffer effects settings.

Share this post


Link to post
Share on other sites

Are you guys sure? I always thought those kind of effects were controlled by the frame buffer effects settings.

Should I disable frame buffer effects then? 

Share this post


Link to post
Share on other sites

Should I disable frame buffer effects then? 

You shouldn't quote me on this, but I remember having the setting on to make all those graphical enhancements appear. However, I also vageuly remember the type of graphics card affecting those settings as well. 

Share this post


Link to post
Share on other sites

Mods? Something seems to be affecting your CM_baremetal.

I know this is a silly question, but is CM_baremetal referring to the bare metal textures?

Share this post


Link to post
Share on other sites

I know this is a silly question, but is CM_baremetal referring to the bare metal textures?

Yes it is. However, this looks like the "stealth field" pattern you see before the character becomes invisible.

 

Have you tried checking your graphical settings in the game menu to see if Frame Buffer Effects is checked?

 

I remember way back when, my computer didn't support them, so I had them unchecked with similar results.

 

I am also lead to believe this since the droid overlay, premonition effect, and stealth effect are Frame Effects, IIRC.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this