KOTOR Script Tool - Error

Recommended Posts

I have been doing scripts for KOTOR 2 , so i can execute them by using JC's toolbox

when i compile script as K1 , everything is ok

But when i tried to compile as K2 , i get this error

My KOTORs are steam version


I also installed KOTOR Tool as well , both K1 and K2 have nwscript.nss in their override folders

Both K1 , K2 root paths are set


D:\Program Files (x86)\Steam\steamapps\common\swkotor


D:\Program Files (x86)\Steam\steamapps\common\Knights of the Old Republic II


Please help me to solve this problem

What is that NeverWinterNights?

Is there a way to fix it?


Share this post

Link to post
Share on other sites
4 minutes ago, Hunters Run said:

I had the same problem. It turns out that the path to the game wasn't set correctly in my registry. In the end I had to set it manually. 

Set it manually on Kotor Script or Kotor Tool?

I set up manually K2 in Kotor tool but having the same problem

Is because of i installed TSLRCM mod?

Share this post

Link to post
Share on other sites
1 hour ago, Hunters Run said:

Sorry if I wasn't clear enough. I had to set the path manually  in the registry itself.  Before you do that read this thread:


Setting it manually should be a last resort. 

Got it , thank you so much man ❤️

Share this post

Link to post
Share on other sites

I'm having the OP issue as well. I had moved my LucasArts games to the partitioned off drive D after they were originally installed on C (from CDs).

I don't know how to update the registry with the new path (KOTOR Scripting Tool is using the old C Drive path).

Is the text in this link applicable to Windows 10, with the game installed from CDs, and is this applicable to KOTOR Scripting Tool?

(I don't know if I followed the instructions if it would be HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BioWare\SW\KOTOR and HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LucasArts\KOTOR2 in my case...)

Share this post

Link to post
Share on other sites

I had similar problems at some point where I had two versions of KotOR2 installed, I simply ran the swupdate.exe and it fixed the issue, I tried it because I was trying to save myself hassle messing around in the registry.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.