Marauder

K1 Monitor Frequency Fix

3 posts in this topic

I discovered this a while ago when modding my swkotor.exe file for widescreen resolution.

There is an easy way to make more modes for your monitor to appear, particularly to get around the 75Hz frame rate limit, and without setting the frequency manually. These options will appear to you from the in-game menus. As far as I know it does not give you widescreen resolutions, just the option to change frequency.

All you have to do is edit your swkotor.ini file and add the line "AllowHighMonitorFrequency=1" under [Graphics Options] and you will then be able to use other frequencies like 120Hz or 144Hz if your panel supports it.

[Graphics Options]
RefreshRate=75
Height=1080
Width=1920
AllowHighMonitorFrequency=1

Then start the game and go your graphics options to change your refresh rate.

My reason for posting this is I'm not aware of this being mentioned anywhere before and it's not on pcgamingwiki. Hopefully this will help others who have monitors with frequencies higher than 75Hz. This might also be somewhat helpful combined with V-Sync in some cases if you need that option.

  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, Kainzorus Prime said:

Interesting. Can it also be applied to TSL?

I did give it a try but unfortunately it doesn't work with TSL. I think it's just not available there.. unless someone can find a way to "make" it work or there's a different entry.

Just something interesting to add. You might get hit with the player stuck bug at a higher frequency even with V-Sync on. Normally you need to have a 85Hz, 75Hz, or lower refresh rate and V-Sync on to stop that bug.

The way around that is to get a frame rate capper for your graphics driver. Under Linux I use libstrangle to achieve this but you can get it for Windows for Nvidia and AMD (I don't remember what their software is called but they have them somewhere). This work-around can be tried even if you have a low refresh rate like 60, 75 or 85Hz.. frame rate capping will usually be a better solution than V-Sync in my experience.

For me all I needed to do was cap the FPS at 85 and choose a monitor mode with a higher refresh rate. No more player stuck bug, and lagging from the game is a lot less.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now