Kainzorus Prime

Black Market droid voice clip crash

7 posts in this topic

I have encountered a rather strange issue with 1.5.1. The game crashes at every instance of attempting to speak to the Black Market Droid in the Central Zone. The dialogue attempts to start, then there is about a second of static when the game attempts to play the corresponding audio file, which seems to be either corrupted, or simply unreadable by the game, before crashing. I've discovered that removing the audio files themselves let the dialogue play out smoothly and without incident, and even attempted to manually convert the files from stereo to mono in a possible fix, but without any luck.

 

EDIT: Further testing seems to have revealed the issue - the original voice files are 48000 Hz 320 kbps stereo files. Converting them to joint stereo with the same setting seems to sort out the files, allowing the voice clip to play without crashing.

  • Like 1

Share this post


Link to post
Share on other sites

When you remove the audio and the dialogue plays muted, is there any lip movement with it? The droid might not have physical organic lips, but the equivalent would be flashing lights on the photoreceptors or something like that. It sounds like it might be a case of the model's talk animation being bugged, and removing the audio would possibly circumvent that.

At least, that's the only thing I would expect to cause a crash in normal circumstances. Usually if there is a problem with the audio file, it simply doesn't play. If it is an audio issue, though, it could something weird in the dialogue file, like if it's trying to play both generic droid VO and a specific VO file at the same time.

  • Like 1

Share this post


Link to post
Share on other sites

I've checked this, and no, with the audio files removed, there doesn't appear to be any lipsynch during the conversation, the optics do not "blink", so to speak. But then again, tweaking the joint stereo setting of the files themselves seems to sort the issue, but I'm not convinced this is the only case, with the heavy amount of custom dialogue in the mod. I will report my further findings of such glitches here, if I encounter any along the way.

A little bit of further research reveals that the older set of voicefiles for this particular droid from previous version of the mod does not have the crash present. Those files are Wave PCM unsigned 8bit, 44100Hz, 352kbps, mono files, however. I assume the re-recorded lines were somehow badly encoded, and it's what causes the crashes.

 

A similar screeching static, possibly due to a bad encoding, was found in one of IS-43's files in the Industrial Zone. It's his system overload warning performed by a female voice. However, this particular file does not seem to cause the game to crash.

  • Like 1

Share this post


Link to post
Share on other sites

In my last Playthrough of TSL -and my first time with M4-78- I found exactly the same problem trying to talk with the black market droid, a short sound like static noise and the game crashing.

I found the same issue talking with another droid, the same static noise but the game didn't crash never at that point (sorry but I don't remember the name of the place and the droid, I think by the industrial zone, after the test droids rooms, in a large room filled with computers and screens).

Add: This last droid must be IS-43 mentioned by KP

PS: At that time I assumed was due the different language versions... Long to explain and this is not the correct place but, anyway I was able to finish M4-78 and TSL with my spanish version of KotOR 2.

Share this post


Link to post
Share on other sites

Another update, it seems all of the voice clips of the six-armed maintenance unit in the R&D/Manufacturing Department in the Rogue Employee quest, are broken. Static screeching comes out with every single line of dialogue, although it doesn't result in a crash.

Share this post


Link to post
Share on other sites

PM me one of that droids (the six-armed maintenance unit, that is) files?  I could then check it against one of my copies. 

Share this post


Link to post
Share on other sites

Your sample seems play just fine in GoldWave, but that's outside of the game.  Have you attempted converting these to joint stereo as well?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now