Sign in to follow this  
Allastair

TSL Patcher - can't choose game folder

11 posts in this topic

I am running KOTOR 2 through Steam on a brand new Windows 10 Laptop. I have tried different versions of both TSL and M4-78 (Steam's versions and through NexusMods) each time with a fresh install of Steam. When attempting to install Mods that use the TSLPatcher.exe, it allows me to get to where I can tell it to install, but never gives me the option to tell it where the Game Folder is located like it is supposed to. Because my C: drive is a small SSD I install all my games and other programs to the D: drive (don't know if this is an issue, but doesn't seem like it would be). 


 


I am attaching a picture that shows what the installer does when I try to install any mods...


This one doesn't show any Game Folder, but after it sits a while it eventually pops up with "Game Folder: User Selected."


 


Mods that I have tried to install using this are few, but they are as follows:


M4-78EP_1.2.4


M4-78 from NexusMods


Handmaiden4females184


Handmaiden and Female Exile - Disciple and Male Exile Romances


 


What I want to know:


1) Is there something my computer might be doing to prevent me from being given the option to choose a destination folder?


2) If so, how can I fix it?


3) If I can't fix it, is there a way to get into the coding to name the destination drive and folder?


4) Anything else you might know that I wouldn't know to ask about...?


post-41132-0-44153600-1518321566_thumb.png

Share this post


Link to post
Share on other sites

Are you trying to use a TSLPatcher exe that you downloaded to install random mods? That's not how it works. It's not a mod manager or something like that.

 

M4-78 should only be available as its own exe installer. Mods that use TSLPatcher will come with their own copy of it that is set up specifically to install that particular mod.

Share this post


Link to post
Share on other sites

Are you trying to use a TSLPatcher exe that you downloaded to install random mods? That's not how it works. It's not a mod manager or something like that.

 

M4-78 should only be available as its own exe installer. Mods that use TSLPatcher will come with their own copy of it that is set up specifically to install that particular mod.

 

No, I am using the .exe installer provided with each mod. The common denominator just seems to be the patcher itself trying to run on my computer.  Fair question, though.

I would imagine that either a second window would pop up requesting me to direct it to the destination folder or it would have an option for a "browse" button like most other windows programs when installing.

Share this post


Link to post
Share on other sites

​Okay, I figured out how to get it to work... I had previously tried running as admin, but like every other time it appeared to just freeze saying "installations started (date and time)."


However, I wondered if the pop-up to select the installations folder was appearing behind it so after running as admin, I moved it before telling it to install this time and wualla, there it was appearing behind the installer instead of in front of it. 


 


ugh...


Share this post


Link to post
Share on other sites

I am having the exact same problem as the OP with the patcher, except when I try that solution (moving the patcher to see the pop-up underneath), there is no pop-up for choosing the directory. Without a workaround or a fix, I am unable to install any mods that use the patcher. Anyone have any ideas?

Edited by jbeav03

Share this post


Link to post
Share on other sites

After you click the Install Mod button, try pressing ALT + Space and then Enter, then tap the Left Arrow key repeatedly and see if the browse window appears from the edge of the screen.

Share this post


Link to post
Share on other sites

Thanks for the quick reply. I have tried your suggestion. I can move the install window all over just as before, but the browse window does not appear. Any other tricks I can try? A browse button built into the install window would have solved this, but alas the creator of TSL Patcher opted for a pop-up instead.

Share this post


Link to post
Share on other sites

If you pressed the Install Mod button first and it is the main window moving then presumably it is not generating the browse dialogue window at all. What OS are you on?

Your only other practical option would be to set the auto-detect flags in tslpatchdata\changes.ini and have it select the game's install location automatically. Change

LookupGameFolder=0 

to

LookupGameFolder=1

and set

LookupGameNumber=

to either 1 for K1 or 2 for TSL. If you are using the Steam or GOG versions, you will first need to add registry entires to point to your install location, as TSLPatcher only knows about the original CD version. Use the info in this post: https://deadlystream.com/topic/4568-kotor-tool-wont-work/?do=findComment&comment=47386

 

Share this post


Link to post
Share on other sites

You are a life saver! Thank you so much for your help. This worked like a charm. I don't know why that thread didn't pop up when I searched all over the internet for a solution. Once again, thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this