Stuck in HK Factory

Recommended Posts

Hi everyone. I believe I have encountered a game-breaking glitch at the HK50 factory on Telos. In the large room full of enemy HK50s (the room full of windows showing HKs being built) I become trapped because all of the doors are locked (including the one you enter the room from). Attempting to open any of the doors suggests using a nearby terminal. When I use the only terminal in the room it lists two options: Security Cameras, and System Commands. Using either option boots me off the terminal and displays a Convesation Node Error leaving me with no way to escape this room.

1) During the game, when did the problem begin to occur?
When I arrived at this point in the droid factory.

2) Did you install the latest version of the mod? (1.8.4 and 1.2 respectively)

3) What version of the game do you have? (Steam, GOG, 4CD, KotOR Collection?) What region is the game designed for if it's the 4 CD version?

4) Did you update your game as required by your game's region? (4-CD version ONLY)

5) Did you install this over the previous version(s), or did you perform a fresh installation as required by the TSLRCM's read-me file?

6) What other mods have you installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)
Content Pack: Feats and Powers, Canonical Jedi Exile 1.2, Invisible Headgear for TSL, Easy Swoop Racing TSL, Fixed Lightsaber Colors (with glow). All of these are installed through Steam workshop.

7) Can you be more specific about the error? At what point did it happen?
When I arrived in that room. It's also worth noting that EVERY terminal in the factory gives me a Node error, not just the one required to open the doors.

8) Have you tried re-downloading/re-installing the mod?

9) Have you tried using a different save game?
Yes, I reloaded a save during the Handmaiden battle on Telos shortly before the Droid Factory segment begins. Same problem occured.

10) Have you tried starting a new game?
No, as this is very late in the game I've ruled it out as an option.

11) What Operating System do you use? (List Virtual Machines as well if you are using them.)

12) Can you confirm that you see the TSLRCM logo on the the main menu screen?

Share this post

Link to post
Share on other sites

I am not sure about this specific issue but the last conversation node error reported (on Dxun) turned out to be an issue with a non English version, specifically the Italian version - I think.

So, what's your game's language and TSLRCM 's language?

Share this post

Link to post
Share on other sites

Hey guys. Turns out I accidentally installed the French version somehow (doh!). I uninstalled, installed the english version, and reloaded a save before the HK Factory and it worked perfectly.

Thanks for the help.

Share this post

Link to post
Share on other sites

Hey guys,


Hope I'm not too late for this topic! I have the same problem, I get stuck in the big control-center-like room after I kill those 8 HK-50 units and I can't open the door and can't access the terminal w/o getting that darn error.

After reading your topic, it's obvious that my problem is the language: this whole side-quest has appeared to me in Italian from the very beginning. God knows why!? 

Sorry for the n0obness that is to come, but could someone please let me know where exactly should I find this Italian version of this quest so I can un-install it and put the English version in place? I really, really, can't seem to find it nowhere in my PC :/ I bought the game from Steam, if that helps? And if you could tell me where did you get the English version, man, that would be great!


Thanks a lot!

Share this post

Link to post
Share on other sites

Ok, so after my initial post from Jan 2016 I'm not ashamed to say that I quit the game. Until now, almost one year later, when I discovered how to "fix" that issue by mistake.

From the very beginning I had that side-quest with the HK factory in Italian. Everytime I was in the factory with HK-47 and tried to log on the consoles, at one point, I would have got that error with NODE blabla. It was especially annoying when I would reach the main console, and since I would get that NODE error, I could not open the main gates and I could not advance in the game.

I now tried (initially only because I was desperate to play the game again) to switch the game's language to Italian from Steam. Like right-click on the game from Steam -> Properties -> Language -> Italiano. And it worked. Worth mentioning I was already in the HK factory while I did this, so I didn't had to load a previous save from before the factory.

Hope you'll find it useful :)

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.