Sign in to follow this  
Jorak Uln

TSL Steam version Bugs/fixes?

6 posts in this topic

Hi you all, 

 

ive been absent from modding for a very long time now - mainly due to a huge amount of work and a significant lack of time.

Dont know if its possible for me to get it done, but i still have a ton of half finished textures and just want to release that Kotor 2 Overhaul 

not too far in the future.

 

One major obstacle is that d*** Steam version of K2 - they seem to have cut off all CM Cubemaps from the game and thus no shine 

can be added via .txi.

 

To fix this is  very important to ensure the same visual quality on the steam version.

 

I just saw Malkiors post in the transparency issue thread here:

 

http://deadlystream....?hl=transparent

 

and i wonder if thats a .2da issue - 

e.g. i made some parts of the PER_Tr02 texture transparent, assigned a Cubemap via .txi and it looks simply solid - no shine at all ingame:

 

post-11673-0-76237400-1523789729_thumb.jpg

post-11673-0-54334800-1523789749_thumb.jpg

 

Interestingly, it looks transparent without cubemap - it seems, the cubemap was recognised somehow, but without shine effect.

Further, the mining droids do appear shiny, so the effect is disabled for regular textures like floors & walls somehow.

 

Does anyone have an idea what causes that - and probably how to fix it?

  • Like 1

Share this post


Link to post
Share on other sites

Aspyr screwed around with the shaders, so I'd expect that is probably the source of the issue.

I'm not familiar with these - you know, 3d modeling, scripting is not really my cup of tea..

So what do you mean? (How) is it possible to enable those shaders/ make cubemaps work again for TSL steam?

Share this post


Link to post
Share on other sites

It's a programming thing. If you are familiar with the fog issue in Aspyr's version, it's the same thing. You'd have to try utilising the shader hack that is used for the fog fix:

 

https://github.com/HappyFunTimes01/ShaderOverride

 

Thanks! 

However, ive installed the fog fix update (according to Xuuls tutorial here:

)

but the issue still remains - 

 

some textures (walls, doors) recognise the cubemap and are shiny, but especially the peragus tex remains black.

Share this post


Link to post
Share on other sites

Yes, I didn't say that the fog fix would solve your problem. I said the issue was related and you'd probably need the same sort of shader hack to fix it. You'd need to sort it out yourself by using the fog fix as a basis.

 

Alternatively, sELFiNDUCEDcOMA apparently has some secret fix for the lightsaber bug, which might be applicable - http://deadlystream.com/forum/topic/2062-tsl-textures-remastered/?p=62552

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this