13 posts in this topic

I decided to dig deep into this map editor thing and can confirm the editor works. It allows you to input creatures, doors, encounters, merchants, placeables, sounds, triggers, and waypoints. I was able to tweak the module lighting different colors. and select day or night cycle option or both not sure if that works.

Now for the interesting part the map files themselves

1st I look at how the names were structured in the map folder of existing maps

2nd I i created a simple blue 512x512 image saved it as jpg, then gave it a name of a module that didn't have a map.

3rd I opened up the jpg image in a text editor the re saved it in the .map extension and put it into the module folder.

4th Opened up the module editor selected open module project and pointed it to the newely created blue image i made.

Results the map loaded the editor accepted the map and i was allowed to use all functions...So the map extension wasn't a mystery after all it just took some determination to figure out. Now new maps can be created for all the levels... Id appreciate all who can help with this.

Important. you must use th K-Tool to extract the module you want to edit into a folder FIRST as the module editor needs it to load all the dump files into the map editor. This is so everything already in the level can be in its positon.

 

Solved invisible issues thanks to the suggestion by Sithpecter about Z coordinates..

What i did was take a z coordinate from a model that was on the map like this one 10.19682...then i simply change the the last number 2 to a 5 i realized it was important for every model to have its own Z coordinates. Now all models show up where ever placed Now all there is to do is create maps for the Levels

 

http://www.mediafire.com/view/c1ie1c...K2_00009_1.png

Share this post


Link to post
Share on other sites

As to the invisible placeables, did you try right-clicking on them and checking the properties?

 

Also, is it just the placeables that are invisible?

Share this post


Link to post
Share on other sites

As to the invisible placeables, did you try right-clicking on them and checking the properties?

 

Also, is it just the placeables that are invisible?

Yes i just found out that all the Z positions on newly placed models are Zer0.....not just plc but all placed items

Share this post


Link to post
Share on other sites

Yeah, that's a standard feature of the Module Editor. It doesn't track the Z Coordinate, so one is stuck with adding that part in yourself.

Share this post


Link to post
Share on other sites

Yeah, that's a standard feature of the Module Editor. It doesn't track the Z Coordinate, so one is stuck with adding that part in yourself.

I find this odd cause many years ago i used the editor and everything i place showed up fine....but that was win xp

 

To add i am able to edit whats already in module with no problems char, plc, etc

Share this post


Link to post
Share on other sites

I find this odd cause many years ago i used the editor and everything i place showed up fine....but that was win xp

Well, it's theorized that the Z coordinate is stored in the mapinfo.bfd file, and defaults to 0 when not found.

Share this post


Link to post
Share on other sites

Well, it's theorized that the Z coordinate is stored in the mapinfo.bfd file, and defaults to 0 when not found

Fixed the invisible issue how it was done is on the first post....another issue would seem the newly placed items only show up when being loaded from another module. So loading a save state to show the results of the editor will not work...not for me anyway.

Share this post


Link to post
Share on other sites

Fixed the invisible issue how it was done is on the first post....another issue would seem the newly placed items only show up when being loaded from another module. So loading a save state to show the results of the editor will not work...not for me anyway.

 

 

Hey Xedii. I got a problem with a K1 Map. 

Error LOG:

You have the map of this module, but the MapInfo file appears to be incorrect or out-of-date.

HELP!!! Please

 

Share this post


Link to post
Share on other sites

 

Hey Xedii. I got a problem with a K1 Map. 

Error LOG:

You have the map of this module, but the MapInfo file appears to be incorrect or out-of-date.

HELP!!! Please

 

 

First that I've heard of that map info being incorrect or out of date. Did you try and replace the map with another of the same to see if it was an isolated error?

Share this post


Link to post
Share on other sites

Could be they didn't get the updated .bfd file...

Yeah, I ask too!

 

First that I've heard of that map info being incorrect or out of date. Did you try and replace the map with another of the same to see if it was an isolated error?

Yes!

Share this post


Link to post
Share on other sites

Can someone code a new MapInfo? I tried, and then it's never worked again (god, i had a backup :D)

Share this post


Link to post
Share on other sites

Can someone code a new MapInfo? I tried, and then it's never worked again (god, i had a backup :D)

Maybe one day a talented coder will  just create a new editor based on mdl editng....I envision an editor to load an mdl  allow you make changes add new item or rearrange plc, people etc then save the changes as a new mdl/mdx file.....all this in a new U.I. realtime version thats easy to use but only time will tell if this will ever get done.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now