Jump to content


Photo

Help needed fixing my GLIntercept FreeCam


  • Please log in to reply
2 replies to this topic

#1 DarthVarkor

DarthVarkor

    Jedi Apprentice

  • Members
  • PipPip
  • 41 posts
  • LocationValley of the Sith Lords

Posted 17 May 2017 - 12:29 PM

Hey everyone, I'm a bit of a lurker on these forums, so sorry if this is posted in the wrong place!

 

Those of you who know me know I'm currently working on a machinima film series adapting KOTOR 2, the primary method I use for the "free-camera" effect is the GLIntercept FreeCam method, which you can download here: http://deadlystream....eecam-in-kotor/

 

Now, I've been using this software since around 2014 when I began working on the series, and haven't had a single problem with it, yet, the other day, I loaded up the game to capture some footage for my film (CTRL, SHIFT, C, I haven't changed the default keys to toggle the freecam on or off) and my game started doing, well, this: https://www.youtube....h?v=FOibVCdSSao

 

I have no idea what's causing this, I've tried deleting & re-installing the GL software completely, following Xuul's tutorial for it in case I'd forgotten how to install it properly, even tried changing the keys to toggle the free-cam on and off, but it still happens. Weirdly enough, when I booted up the game today, it started working completely normally again, but then started moving of its own free will again shortly after.

 

I'm probably just being a complete idiot and overlooking something, but any help would be really appreciated! 

 

In case they're needed, here are my config files for it from the "Plugins" folder.

Attached Files



#2 tpiom

tpiom

    Jedi Apprentice

  • Members
  • PipPip
  • 56 posts

Posted 17 May 2017 - 10:14 PM

It... looks like it's taking on a life of its own? I've nothing to back this up but I believe there's a key combination that triggers it so it loops the current command, couldn't tell you which on though (once it gets going there's no easy way to stop it other than killing the game and restarting the whole thing)

 

I haven't experienced it in some time though.

What version of gl are you using?

 

If you do re-install/update it it's easy to get going:
1. Install 32-bit (important!) version/x86 of gl, then find its directory (C:\Program Files (x86)\GLIntercept_1_3_3)
2. Copy gliConfig_FreeCam.ini and OpenGL32.dll to your game directory (F:\Program Files\KotOR)
3. Rename gliconfig_Freecam.ini to gliConfig.ini (the _"whatever" is just a template created by them)
4. Open up gliConfig.ini in notepad, scroll down...
make sure all logs = false (setting LogEnabled = False)

Also make sure BaseDir points to C:\Program Files (x86)\GLIntercept_1_3_3\XSL (or whatever your path is)



#3 DarthVarkor

DarthVarkor

    Jedi Apprentice

  • Members
  • PipPip
  • 41 posts
  • LocationValley of the Sith Lords

Posted 17 May 2017 - 11:30 PM

Hey, tpiom, that's basically what I just did about 30 mins before seeing your reply on here, weirdly enough, after a full re-install, I loaded up K2, used the command keys to activate the free-camera and it started doing it again! But I seemed to be able to change the direction it was moving by pressing the directional control keys for it, very weird. But then, say if it was tilting left, I hit the key once for tilt left, it stopped! And it hasn't come back since on either K1 or 2, really weird.

 

I think it's to do with the shift key, not only is it the modifier for the speed of the camera, but holding it whilst holding down the tilt buttons seems to lock it in that direction, and only tapping said key again on its own without shift seems to stop that, too. I'm just gonna put it down to me being clumsy with what keys I'm pressing. Panic over! 


  • jc2 likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users