Skeet1983

RCM 1.8.5 Telos Game Crash

9 posts in this topic

I have the Steam version of TSL and am using RCM 1.8.5. Anyway, the game crashes just as I start to talk to Bao-Dur after Shuttle crashes on Telos. The only other mod I am using besides RCM is the Hak_Pad mod. I am also running game on Windows 10 64-bit. Thoughts and help appreciated  :)

Share this post


Link to post
Share on other sites

I'm not sure if it's exclusive to the RCM and the Steam/Aspyr version in conjunction, but here's how to fix it:

go to your SWKOTOR2.ini and find "DisableVertexBufferObjects=1"

Under it, paste "Disable Vertex Buffer Objects=1"

 

Note: When you reach Onderon, after the cutscene before the spaceport loads, the game will also crash with this setup (Steam, RCM 1.8.5+"DisableVertexBufferObjects=1")

So go back and set it to 0 instead of 1, at least for the duration of that cutscene.

 

Edit: 

I can't remember for sure, but it might be vice versa: ("DisableVertexBufferObjects=0" for Telos, "DisableVertexBufferObjects=1" for Onderon)

Share this post


Link to post
Share on other sites

I'm not sure if it's exclusive to the RCM and the Steam/Aspyr version in conjunction, but here's how to fix it:

go to your SWKOTOR2.ini and find "DisableVertexBufferObjects=1"

Under it, paste "Disable Vertex Buffer Objects=1"

 

Note: When you reach Onderon, after the cutscene before the spaceport loads, the game will also crash with this setup (Steam, RCM 1.8.5+"DisableVertexBufferObjects=1")

So go back and set it to 0 instead of 1, at least for the duration of that cutscene.

Onderon, or Telos? My game crashes just after the cutscenes where I take Shuttle from Citadel to Telos surface...

Share this post


Link to post
Share on other sites

Onderon, or Telos? My game crashes just after the cutscenes where I take Shuttle from Citadel to Telos surface...

Both. Whatever you do to fix this, you'll have to undo it to fix Onderon.

Share this post


Link to post
Share on other sites

Both. Whatever you do to fix this, you'll have to undo it to fix Onderon.

Ok, it did work  :)

 

I set vertex objects to 0, and game didn't crash :)

 

I am now on Telos surface in Restoration Zone. Should I leave vertex objects set to 0, or go back to 1? Also, what do I need to do to prevent Onderon crash in RCM 1.8.5?

Share this post


Link to post
Share on other sites

Ok, it did work  :D

 

I set vertex objects to 0, and game didn't crash :D

 

I am now on Telos surface in Restoration Zone. Should I leave vertex objects set to 0, or go back to 1? Also, what do I need to do to prevent Onderon crash in RCM 1.8.5?

You can set it to 1 once you leave the restoration zone. In order to prevent Onderon from crashing in the spaceport cutscene, you need to set it to 1 anyway. I think actually though, once the intro cutscene for the spaceport is over, you can set it back to 0 if you want. It's very important to set that setting back to 0 before you finish the Ravager or a certain character who shows up will have the most glitched up head ever.

  • Like 1

Share this post


Link to post
Share on other sites

You can set it to 1 once you leave the restoration zone. In order to prevent Onderon from crashing in the spaceport cutscene, you need to set it to 1 anyway. I think actually though, once the intro cutscene for the spaceport is over, you can set it back to 0 if you want. It's very important to set that setting back to 0 before you finish the Ravager or a certain character who shows up will have the most glitched up head ever.

After leaving Telos Polar Region, I reset vertex objects back to 1. I then went to Nar Shadaa, but game crashed again just when Go-to was talking about the Exiled Jedi. When I set vertex objects to 0, that part didnt crash and I was able to land on Nar Shadaa. Should I just leave vertex objects set to 0, and then re-enable when I get to the Ravager? You said I need it set to 1 for Onderon... What should I do? Thoughts and help appreciated  :D

Share this post


Link to post
Share on other sites

I can't really remember what all I did. I think what I did was leave it alone until I left Dxun the first time and then I left it alone until I finished the return to Telos and, after seeing a character's head horribly deformed due to what looked like, eyelashes screwing up, I changed it again.

 

Out of curiosity, are you on an NVIDIA card? If so, what card and what driver?  

Share this post


Link to post
Share on other sites

I can't really remember what all I did. I think what I did was leave it alone until I left Dxun the first time and then I left it alone until I finished the return to Telos and, after seeing a character's head horribly deformed due to what looked like, eyelashes screwing up, I changed it again.

 

Out of curiosity, are you on an NVIDIA card? If so, what card and what driver?  

Yes, my laptop has 2 Nvidia Cards. It has 2 Nvidia GeForce GTX 870Ms with 6GB each. Driver is 376.54.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now