Jump to content


revan21

Member Since 27 Feb 2015
Offline Last Active Yesterday, 03:00 PM
-----

Topics I've Started

Armor Mod Compatibility

13 November 2016 - 06:48 PM

Hello Deadlystream !  :welcome:

 

After a good year of using the amazing Loot and Immersion by 90SK I decided to try something new in terms of armor mods. Im concerned about the compatibility of these mods:

 

Movie Jedi Master Robes 1.5

Darth Darkus' Armored Robes 1.3.1 Master Jorn Edition

L0ki's Jedi Armor Mod

Cortosis Armor Merchant

Heavy Armor Expansion

Peragus Mining Gear

Prequel Robe Replacer

Unique Upgradeable Clothes

Combat Suit Revisited

Canonical Mandalore

 

Im gratefull for any advice I get concerning this matter. 

(This is my first forum post so this might be in the wrong section of the forum)