Jump to content


Photo
- - - - -

Mod Compatibility with TSLRCM 1.8


  • Please log in to reply
204 replies to this topic

#1 Hassat Hunter

Hassat Hunter

    Beta Testing Monkey

  • Administrators
  • 3,420 posts

Posted 22 July 2012 - 11:01 PM

http://deadlystream....-for-tslrcm-18/
Check here for the known list of working and non-working mods.
If the one you wonder about isn't listed, feel free to ask here if anyone knows it's (in)compatible. And we'll add them to the list later.

#2 Robinson96

Robinson96

    Jedi Initiate

  • Members
  • Pip
  • 4 posts

Posted 24 July 2012 - 09:00 PM

What exactly is the problem with shems super enhanced mod with TSLRCM, will it work with 1.8?

#3 fitscotgaymer

fitscotgaymer

    Jedi Initiate

  • Members
  • Pip
  • 9 posts
  • LocationScotland, UK

Posted 24 July 2012 - 10:47 PM

So 1.8 wont work with USM at all?

Even with the compatibility "patch"?
"Superior training and superior weaponry have, when taken together, a geometric effect on overall military strength. Well-trained, well-equipped troops can stand up to many more times their lesser brethren than linear arithmetic would seem to indicate." -- Colonel Corazon Santiago, Spartan Battle Manual : Sid Meiers' Alpha Centauri

#4 milestails

milestails

    Jedi Knight

  • Members
  • PipPipPipPip
  • 326 posts

Posted 24 July 2012 - 11:00 PM

Just want to point out that DarthJacen's Movie-Style Retextures in the compatibility list is v7. DarthJacen released a v8: http://knightsoftheo...g_Blades;119330

#5 Ferc Kast

Ferc Kast

    Jedi Apprentice

  • Members
  • PipPip
  • 34 posts

Posted 24 July 2012 - 11:33 PM

Does TSLRCM 1.8 modify 101awake.dlg from the Peragus Administration level? Just curious since I don't recall seeing it in what little I played with 1.7

#6 drunklol

drunklol

    Jedi Apprentice

  • Members
  • PipPip
  • 34 posts

Posted 25 July 2012 - 07:52 AM

So I have been using some mods which were compatible with TSLRCM 1.7 but I am not sure they will remain as such in the new 1.8, so these are the mods:
K1 Cloaked robes
Ultimate Personal Items
TSL Saber Replacement Hilts
Ultimate Balancing mod
Canonical Jedi Exile
Canonical Mandalore
Armored Robes
It would be much appreciated to know if some of these aren't compatible. If some are incompatible, I'd like to know why that is so and how they could be changed to be compatible.

#7 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 1,752 posts
  • LocationMaryland (Nar Shaddaa East)

Posted 25 July 2012 - 08:03 AM

Just want to point out that DarthJacen's Movie-Style Retextures in the compatibility list is v7. DarthJacen released a v8: http://knightsoftheo...g_Blades;119330


Since the TSLRCM 1.8 was just released, that's why we don't have the most current version up there.

Milestails, if you would test out the DarthJacen's Movie-Style Retextures version 8 with TSLRCM 1.8 so we may add it to the list, that would be both helpful and appreciated.
Release dates are for those that don't care about quality in mods.

#8 kyrie

kyrie

    Jedi Knight

  • Members
  • PipPipPipPip
  • 155 posts

Posted 25 July 2012 - 10:42 AM

I didn't notice if VP's handsister fix is still compatible. I did see that there is a handsister mdl and mdx file in tslrcm thou.

#9 DeadMan

DeadMan

    Jedi Padawan

  • Members
  • PipPipPip
  • 83 posts
  • LocationRussia

Posted 25 July 2012 - 04:24 PM

Here's the list of my mods, which 100% will work with 1.8:
TFU-Style Darth Sion model
Saber&Melee Weapon Sound Mod
TFU Lightsaber pikes
New Saber Blades
Ep.3 Anakin Skywalker
Vibrosword Replacement Pack
Movie-style Jedi Master robes


Movie Mandalorians SHOULD work properly, but I didn't had time to test it yet, so at this point use on your own risk.
The greatest programming project of all time took six days; on the seventh day the programmer rested. We've been trying to debug that f@#$%ng thing ever since.
Moral: design before you implement.

Stay metal, live forever, never die!

#10 Aizen

Aizen

    Jedi Initiate

  • Members
  • Pip
  • 1 posts

Posted 25 July 2012 - 07:12 PM

I installed TSLRCM 1.8, now I want to install High Quality Movies Patch. Can I do it? Or do I have to install the patch first, and then TSLRCM?

Thank u very much!

#11 tpiom

tpiom

    Jedi Apprentice

  • Members
  • PipPip
  • 38 posts

Posted 25 July 2012 - 07:33 PM

I installed TSLRCM 1.8, now I want to install High Quality Movies Patch. Can I do it? Or do I have to install the patch first, and then TSLRCM?

Thank u very much!


Doesn't matter... I don't think the mod changes any movie files so you're safe.

#12 darthshot

darthshot

    Jedi Initiate

  • Members
  • Pip
  • 3 posts

Posted 25 July 2012 - 08:44 PM

Hi! I would like to know if the following mod is compatible with 1.8:

Kreia's Assorted Robe Collection

thanks!

#13 Darth Paulus

Darth Paulus

    Jedi Apprentice

  • Members
  • PipPip
  • 51 posts

Posted 25 July 2012 - 09:41 PM

Hey, guys, just to notify you, these two mods are most likely INCOMPATIBLE with 1.8 (at least there are same/conflicting files in Override):

Expanded Workbench Revised Revision 2.02 by Vanaheim (AKA Vanir)
Remote Tells Influence by tk102

Too bad, both of them were very useful...

#14 darthshot

darthshot

    Jedi Initiate

  • Members
  • Pip
  • 3 posts

Posted 25 July 2012 - 10:25 PM

Hey, guys, just to notify you, these two mods are most likely INCOMPATIBLE with 1.8 (at least there are same/conflicting files in Override):

Expanded Workbench Revised Revision 2.02 by Vanaheim (AKA Vanir)
Remote Tells Influence by tk102

Too bad, both of them were very useful...

The remote tells influence is on the compatible list so i guess it works!

#15 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 1,752 posts
  • LocationMaryland (Nar Shaddaa East)

Posted 25 July 2012 - 10:36 PM

I installed TSLRCM 1.8, now I want to install High Quality Movies Patch. Can I do it? Or do I have to install the patch first, and then TSLRCM?
Thank u very much!


Doesn't matter... I don't think the mod changes any movie files so you're safe.


Aizen, you should probably install the High Quality Movies Patch before installing TSLRCM 1.8 and here's why . . .

1) The original BIK movie file where we first see Visas and Nihilus is replaced by an in-game cut-scene in TSLRCM 1.8.

2) The original BIK movie where we see Sion on the bridge of the Harbinger has been altered. The BIK scene has been split into two parts - the space portion of that movie file. The middle portion that has Sion in it is also made as a cut-scene made with the game's engine like in (1).

By putting in the HQ Movie patch after TSLRCM 1.8, you're definitely screwing up number 2, and possibly messing up number 1.
Release dates are for those that don't care about quality in mods.

#16 milestails

milestails

    Jedi Knight

  • Members
  • PipPipPipPip
  • 326 posts

Posted 25 July 2012 - 10:44 PM

Workbench Crystal Attunement is not compatible. At least there is a workbench.dlg in the mod and in Override after 1.8 is installed. Correct me if I'm wrong.

Also I noticed that there are a few lightsaber/doublesaber/shortsaber .mdl and .mdx files (10 and 11 I believe) after installing. What do these do exactly? They conflict with TSL Replacement Hilts MegaPack 4.1. Additionally, the new bronze/orange textures from TSLRCM conflict with it as well. But I'm assuming it's a matter of preference for how one sees bronze and orange?

I noticed that Shem's Enhanced Merchants is on the incompatibility list because of changes to the random loot system. While I don't use his mod, am I correct in saying any mod which modifies merchants i.e. uses .utm files will be incompatible as well?

#17 Darth Paulus

Darth Paulus

    Jedi Apprentice

  • Members
  • PipPip
  • 51 posts

Posted 25 July 2012 - 11:17 PM

The remote tells influence is on the compatible list so i guess it works!


Sadly enough, no. These entries on the list are apparently taken from 1.7 list and specifically, this one (and the second one with workbenches) is wrong. The Override folder now contains remote.dlg file (since 1.8 fixes some remote's features}.

As for the list - the compatibility of all the mods must be re-confirmed for brand new 1.8.

#18 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 1,752 posts
  • LocationMaryland (Nar Shaddaa East)

Posted 25 July 2012 - 11:26 PM

Sadly enough, no. These entries on the list are apparently taken from 1.7 list and specifically, this one (and the second one with workbenches) is wrong. The Override folder now contains remote.dlg file (since 1.8 fixes some remote's features}.

Please note that the thread was originally the thread for TSLRCM 1.7. I will go on record as saying that I did not simply re-title the thread.

That would be some one else.

As for the list - the compatibility of all the mods must be re-confirmed for brand new 1.8.

Agreed.
Release dates are for those that don't care about quality in mods.

#19 milestails

milestails

    Jedi Knight

  • Members
  • PipPipPipPip
  • 326 posts

Posted 25 July 2012 - 11:29 PM

Hi! I would like to know if the following mod is compatible with 1.8:

Kreia's Assorted Robe Collection

thanks!


It is not compatible. See here: http://deadlystream....n/page__st__340

#20 Traveller

Traveller

    Jedi Apprentice

  • Members
  • PipPip
  • 36 posts

Posted 26 July 2012 - 12:28 AM

Also I noticed that there are a few lightsaber/doublesaber/shortsaber .mdl and .mdx files (10 and 11 I believe) after installing. What do these do exactly? They conflict with TSL Replacement Hilts MegaPack 4.1. Additionally, the new bronze/orange textures from TSLRCM conflict with it as well. But I'm assuming it's a matter of preference for how one sees bronze and orange?

I simply removed the TSLRCM versions from the Override folder. Since they are only textures and models, their replacement with the equivalent models from the Replacement Hilts MegaPack shouldn't affect gameplay.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users