Jump to content


Photo

Black Line in middle of face.


  • Please log in to reply
45 replies to this topic

#1 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 19 August 2017 - 10:02 AM

Anyone know what causes this black line in the middle of the face? (seen here on Mission.)

It doesn't show in any of the closeup talking scenes.

I think it is shadow related.

It's making Mission go cross-eyed just looking at it.

 

hstVuo2.jpg



#2 DarthParametric

DarthParametric

    Dark Lord of the Sith

  • Members
  • PipPipPipPipPip
  • 1,073 posts
  • LocationOz

Posted 19 August 2017 - 10:15 AM

A poor job on the part of whoever did the retexture, presumably.

#3 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 19 August 2017 - 10:26 AM

A poor job on the part of whoever did the retexture, presumably.

Well I did the retexture, so I can't rule that out, but it doesn't show when the texture is in model viewer, or in close up scenes.
If it was a fault in the retexture wouldn't it always be there?
km3NBTt.jpg 
 
tjenQdw.jpg

EDIT:
I switched back to the default texture but the line is still there.

A26ZauP.jpg



#4 DarthParametric

DarthParametric

    Dark Lord of the Sith

  • Members
  • PipPipPipPipPip
  • 1,073 posts
  • LocationOz

Posted 19 August 2017 - 11:02 AM

Could be related to the GPU I guess. Not an integrated GPU by any chance is it? A laptop?

#5 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 19 August 2017 - 11:38 AM

Could be related to the GPU I guess. Not an integrated GPU by any chance is it? A laptop?

No,  GTX1080 desktop, current Win10 drivers.

If no-one else is getting it, I might try reinstalling the game.

 

Edit: I tried setting the game to maximum performance in the Nvidia Control Panel in case it was using the integrated gpu chip, but it made no difference.

I just noticed Carth has a bit of it too, but it's not so noticeable .

 

http://i.imgur.com/jtIF5Ti.jpg


Edited by olnorton, 19 August 2017 - 11:52 AM.


#6 LucyTheAlien

LucyTheAlien

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 710 posts
  • LocationNorthern Ireland

Posted 19 August 2017 - 11:54 AM

It's just the seam line in character model, Atton Rand has a prominent one I've found. Not nearly as bad as it's appearing on Mission for you though.
One will make the choice- all will make the journey.

#7 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 19 August 2017 - 12:14 PM

It's just the seam line in character model, Atton Rand has a prominent one I've found. Not nearly as bad as it's appearing on Mission for you though.

Thanks for the input, I wonder if the uniws mod and running @ 1440x900 is making it worse.

When I finish this playthrough, I'll reinstall the game and try it with the default aspect ratio.



#8 DarthParametric

DarthParametric

    Dark Lord of the Sith

  • Members
  • PipPipPipPipPip
  • 1,073 posts
  • LocationOz

Posted 19 August 2017 - 12:15 PM

Not seeing it myself on a 1080 running at 1080p via UniWS. Any specific locations where it occurs, or everywhere outside of dialogue?

#9 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 19 August 2017 - 12:19 PM

Not seeing it myself on a 1080 running at 1080p via UniWS. Any specific locations where it occurs, or everywhere outside of dialogue?

Not everywhere, mostly in brightly lit areas.

Sometimes she will just stand in one spot, moving her head a little and it will come and go as she moves



#10 DarthParametric

DarthParametric

    Dark Lord of the Sith

  • Members
  • PipPipPipPipPip
  • 1,073 posts
  • LocationOz

Posted 19 August 2017 - 12:27 PM

If you have a save where it occurs, that would be useful.

Your retexture only changes the texture itself, not the model I assume?

#11 LucyTheAlien

LucyTheAlien

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 710 posts
  • LocationNorthern Ireland

Posted 19 August 2017 - 12:29 PM

Hmmmmmm... I'm staying at a friend's while my stuff is being moved to a house in England so I don't have access to my computer ATM but...

https://drive.google...Ym9xMjdNQkwzcDA

There's a link to my set up, I haven't noticed the seams in a while so I think I must be doing something right.
One will make the choice- all will make the journey.

#12 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 19 August 2017 - 01:30 PM

If you have a save where it occurs, that would be useful.

Your retexture only changes the texture itself, not the model I assume?

Yes, only the textures.
But I don't think the problem is in the save, because it was like that in my previous game with a different character.


There's a link to my set up, I haven't noticed the seams in a while so I think I must be doing something right.

Thanks Lucy, other than the resolution, your ini looks pretty much the same as mine.
I didn't like 1080p when I tried it because the UI got a bit small for my liking.

Attached Files



#13 DarthParametric

DarthParametric

    Dark Lord of the Sith

  • Members
  • PipPipPipPipPip
  • 1,073 posts
  • LocationOz

Posted 19 August 2017 - 02:05 PM

There's no issue with Mission readily apparent for me when loading that save.

The drivers you are running are 385.28 WHQL? I'm still on 384.76 WHQL myself.

#14 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 19 August 2017 - 02:38 PM

There's no issue with Mission readily apparent for me when loading that save.

The drivers you are running are 385.28 WHQL? I'm still on 384.76 WHQL myself.

No, I'm still on 384.74 WHQL as well.
I just tried it with Lucy's setup (her kotor.exe and ini files and the 1080p ui files)
It's still there on Mission, and it is even on Bastila on the levelup screen.
0yAEJ1y.jpg

fUFd0M2.jpg

If I move the camera a bit, the line disappears, but then my PC looks too much like Prince from this angle.NjEmrvB.jpg



#15 DarthParametric

DarthParametric

    Dark Lord of the Sith

  • Members
  • PipPipPipPipPip
  • 1,073 posts
  • LocationOz

Posted 19 August 2017 - 03:03 PM

Yeah dunno what to say. Not seeing it here on default settings or with my usual forced overrides via the nVidia control panel (AA and so forth). There's got to be something at your end causing it.

#16 Kexikus

Kexikus

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 1,345 posts

Posted 19 August 2017 - 08:58 PM

I had this issue as well but IIRC only with retextured characters. I think it was Canderous or Carth in my case. My assumption was always that it's a mistake with the texture's alpha channel but apparently it's not. Really weird...



#17 ndix UR

ndix UR

    Jedi Apprentice

  • Members
  • PipPip
  • 58 posts
  • Locationca, usa

Posted 19 August 2017 - 09:48 PM

I also regularly experience this issue. It seems to be an issue with the algorithm in the game for getting data to make mipmaps from. Mipmaps are smaller versions of your texture which the game uses for rendering at different distances. This is why close up you (almost) never see this issue, and it is generally very affected by camera angle/distance.

 

You can reduce the issue by making sure that all your UV islands have nice big like-colored dead zones/borders around them. I didn't know this early on and have paid the price.

 

The game's mipmaps are 1/2 size at each 'level'. So, at the first level, your UV island border pixels are blended with 1 pixel (from the original sized image) from across the border. At the 2nd level, 2 pixels, 3rd level 4 pixels, 4th level 8 pixels, 5th level 16 pixels. It's a bit more complicated than that, but that is kind of the general idea. You have to balance the size of your border areas with the level at which the mipmap has so little detail it doesn't really matter. Like, a 2K texture will have 11 mipmap levels, which would need UV island borders of 1024px to be "perfect" at the last level ... but that last level is only 1 pixel, so what detail would you really be trying to preserve with that?

 

For me, personally, I find 16px for 2K textures to be a good balance.

 

A reason why you see this less in default textures is that they use the TPC format, which includes precomputed mipmap images (for which, presumably, they took care to make sure the mipmaps came out with good visual characteristics). TGA images don't have mipmaps, so they are generated by your video card (there is an OpenGL function that does this), which is also why there is some variance w/ different cards/drivers/etc. Seems like driver-level AA settings would help too, but in-game AA settings don't seem to affect the issue.

 

In an ideal world, the mipmap generation would use UV mapping to refrain from using pixels from outside the UV islands, but that is not 2003 tech :)

 

My understanding for why this issue never really goes away is that the game seems to maybe use black pixels when a mipmap is blending with pixels outside the border of the image. That is just a theory though.



#18 DarthParametric

DarthParametric

    Dark Lord of the Sith

  • Members
  • PipPipPipPipPip
  • 1,073 posts
  • LocationOz

Posted 20 August 2017 - 03:54 AM

Hrm, an interesting hypothesis. Seeing as this is using the vanilla model, there's no simple solution on the UV side. Post #3 would suggest it is still happening with the vanilla TPC, assuming that OP deleted their TGA rather than replacing it with a TGA of the original texture.

I did actually release a modified Mission head merging in the UVs from her lekku so that she could use a single head texture. I could try remapping that to add more padding around UV boundaries.

#19 sELFiNDUCEDcOMA

sELFiNDUCEDcOMA

    Sith'ari

  • Members
  • PipPipPipPip
  • 304 posts
  • LocationLand of Oz

Posted 20 August 2017 - 05:44 AM

My understanding for why this issue never really goes away is that the game seems to maybe use black pixels when a mipmap is blending with pixels outside the border of the image. That is just a theory though.

 

I've noticed the issue as well; decided it was a UV mapping issue but mipmaps themselves didn't come to mind. Seems very likely it is based on your reasoning.

 

From memory, if you use textures that also make use of a specularity texture via a TXI file, the black line will be less visible if not negated -- depends on resolution. As any retextures I do generally make use of one -- beyond those that need to use the alpha channel for transparency, like Atton -- so I find this problem disappears for me for the most part.



#20 olnorton

olnorton

    Jedi Apprentice

  • Members
  • PipPip
  • 20 posts

Posted 20 August 2017 - 05:46 AM

Thanks all for your input.  :thumbsup:

Well I reinstalled the game, no overrides or mods.

Set in game settings to high except default 800 x 600 resolution.

I did a clean install of the 385.28 WHQL drivers (all default settings)

Mission still has a noticable black line.

 

ScsqeQo.jpg

 

In the Nvidia Control Panel, I usually just set the "Use my preference emphasising: Quality"

"Perform scaling on: GPU", "Override the scaling mode set by games and programs" and leave the rest alone.

I set the Global Settings  "Anisotropic filtering 16x" , " Antialiasing - Mode Override any application settings" and "Antialiasing - Setting  8x"  but it made no difference.

 

So I'll stick the mods back, try and forget about it, get back to retexturing everything, and maybe playing the game too.

 

EDIT:

Well it is definitely effected by resolution.

I just changed to 1600x1200 with everything stock and the line is gone. (well at least in this lighting where it has previously been there.)


Edited by olnorton, 20 August 2017 - 06:08 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users