Jump to content


Photo

Galaxy Map issue - M4-78 and Coruscant crossing


  • Please log in to reply
16 replies to this topic

#1 Xr900

Xr900

    Jedi Apprentice

  • Members
  • PipPip
  • 12 posts

Posted 16 June 2017 - 02:37 AM

Hello,

 

I have a problem with Galaxy map where the Coruscant (Jedi Temple) is crossing with what seems to be Mr-78 and it looks like this: 

 

Attached File  Screenshot 2017-06-16 03-59-37.png   1.21MB   0 downloads

 

I have checked where it will take me, and I went to Coruscant (planet content works fine btw). I wasn't on Korriban yet, so I have no idea whether the planet M4-78 will appear elsewhere on the map or not.

 

As for the installation itself, I have Steam version of TS. I have installed Jedi Temple with Expansion as the instruction explained

- I already had M4-78 installed (Steam workshop)

- I have then downloaded and installed Jedi Temple on Coruscant in the TSL override folder

- Then I have installed an expansion with compatibility update.

 

I thought that Animated galaxy map might be causing problems, but removing it didn't help. I have even tried installing Galaxy Map Fix but that didn't help either, planets are still in the exact same positions on the galaxy map. As I said, I wasn't on Korriban yet so I have no idea how will that look afterward. Anyway, here are all the answers in the proper format:

 

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 

1) During the game, when did the problem begin to occur? (List a general description of the issue.)

- When I opened Galaxy Map after leaving Telos

2) Did you install the latest version of the mod? (We are only covering issues concerning version 1.3 - the latest edition.)

- I think so, it's Steam version.

3) What version of the game do you have? (Steam, GOG, 4CD, or the KotOR Collection?) What region is the game designed for if it's the 4 CD version?

- Steam version

4) Did you update your game as required by your game's region? (Update is required for 4-CD version only. If using a Steam, KOTOR Collection, or GOG version, put down "N/A")

- N/A

5) Did you use the TSLPatcher, if provided?

- Yes

6) Were there any errors in the TSLPatcher installation?

- No

7) What other mods have you installed? Please give an accurate list and provide links to each of these mods - even if they are found on this site. (We don't actually know them all!.)

- None relevant to this issue I believe. I think that I somehow messed up the installation of Jedi Temple with Expansion, but I have installed compatibility fix properly (I believe) and I even tried installing  galaxy map fix as explained above. Didn't help. 

8) Can you be more specific about the error? At what point did it happen? (List a detailed description of the issue.)

- I have described the problem above the Q&A

9) Have you tried re-downloading the mod?

- Nope. I fear that attempting to reinstall the mod in the current state may corrupt my save file and I will have to restart the entire game, I don't want that.

10) Have you tried using a different save game?

- Nope, I am using quicksave all the way.

11) Have you tried starting a new game?

- Nope, I am too far to do that now.

12) What Operating System do you use? (List Virtual Machines as well if you are using them.) If you're a Mac user, please note that here as well.

- Windows 7

 

 



#2 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 3,767 posts
  • LocationKodiak, AK (Hoth)

Posted 16 June 2017 - 02:50 AM

If you're using the Steam version of M4-78 EP - which is newer than any version posted elsewhere - I suggest also posting on Steam to acquire answers as well.  

 

A question: Are you using the Workshop versions of TSLRCM and M4-78 EP?  I hesittate to go much further with this assistance due to my complete inexperience with using the Workshop.  However, others are sure to know more both here and definitely on Steam's forums.

 

(If you get a reply over on Steam that works, please let us know what it was in this thread.)


"Release dates are for those that don't care about quality in mods." - Me
My mods can be found here.

 

I tend not to accept friend requests from people that I don't know or if they lack a profile picture.


#3 Kexikus

Kexikus

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 1,225 posts

Posted 16 June 2017 - 08:36 AM

The issue comes from using the M4-78 EP Steam version and then installing the other mods to the main TSL Override folder.

 

It is highly recommended to use ONLY TSLRCM from the Steam workshop for the reasons listed in this guide.

However, the Steam version of M4-78 EP might work too if you follow the guide I linked but choose the M4-78 EP workshop folder instead of the TSLRCM one. This will most likely fix your galaxy map issues but it might still lead to incompabilities (quite likely actually).

 

So my suggestion would be to get TSLRCM either from the Steam workshop or from moddb (as it's currently not available here) and then get M4-78 EP from moddb as well. Install both M4-78 EP and Coruscant (including the compability patches) to the TSLRCM workshop folder. The downside to this is that you'll only get M4-78 EP 1.2 and not 1.3 from the workshop. So either try what I wrote above, wait for 1.3 to be released here as well or play with 1.2. Your choice.


Signatur_zpsdlwsov7b.jpg


#4 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 3,767 posts
  • LocationKodiak, AK (Hoth)

Posted 16 June 2017 - 08:40 AM

... wait for 1.3 to be released here 

And if you're wondering why M4-78 EP version 1.3 (or any other version for that matter) isn't here, look at this thread.


"Release dates are for those that don't care about quality in mods." - Me
My mods can be found here.

 

I tend not to accept friend requests from people that I don't know or if they lack a profile picture.


#5 Xr900

Xr900

    Jedi Apprentice

  • Members
  • PipPip
  • 12 posts

Posted 16 June 2017 - 12:14 PM

Yes, I am using workshop versions of  TSLRCM and M4-78 EP. 

 

So far with the current installation of addons this is the only issue I have encountered. Maybe I will simply uninstall Jedi Temple once I will finish with that planet unless there is some more content in that mod related to Coruscant outside of it?



#6 Kexikus

Kexikus

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 1,225 posts

Posted 16 June 2017 - 02:58 PM

Yes, I am using workshop versions of  TSLRCM and M4-78 EP. 

 

So far with the current installation of addons this is the only issue I have encountered. Maybe I will simply uninstall Jedi Temple once I will finish with that planet unless there is some more content in that mod related to Coruscant outside of it?

 

Have you read my post?

 

Also, uninstalling a mod mid playthrough can always cause issues even if the majority of the content is in the past, so I'd advise against that and go with one of the solutions I posted above.


Signatur_zpsdlwsov7b.jpg


#7 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 3,767 posts
  • LocationKodiak, AK (Hoth)

Posted 16 June 2017 - 03:06 PM

Hopefully, he's learned his lesson about having multiple saves from now on.

"Release dates are for those that don't care about quality in mods." - Me
My mods can be found here.

 

I tend not to accept friend requests from people that I don't know or if they lack a profile picture.


#8 Xr900

Xr900

    Jedi Apprentice

  • Members
  • PipPip
  • 12 posts

Posted 16 June 2017 - 09:04 PM

Kexikus I have followed your instructions,

 

- kept TSLRCM from workshop installed

- unsubbed from M4-78 and it's contents copied to TSLRCM folder (so I can enjoy the latest version of this mod)

- I have done the same thing with Jedi Temple and it's compatibility patches

 

As a result, the glitched text is no longer shown for the Coruscant. In fact, no text is shown at all, but at least it's not crossing with M4-78, so that's a step forward.

 

Attached File  Screenshot 2017-06-16 22-52-55.png   1.15MB   0 downloads

 

One thing I don't understand is how can multiple save files help.



#9 Kexikus

Kexikus

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 1,225 posts

Posted 17 June 2017 - 08:47 AM

The missing text comes most likely from simply copying the files as I bet you had some cases where a file existed twice and you had to choose one, right? These would have been merged by properly installing the mods instead of just copying files (or at least properly installing the Jedi Temple and the patches, the copy of M4-78 should actually be fine).

 

Multiple saves might not actually help in this special case but it's generally a very, very good idea to keep multiple saves especially when playing with mods. The reason for this is that some data from mods is stored in the savegame while playing and if this content causes game breaking bugs, you want to have an earlier savegame that doesn't have the content yet so that you can go back there, remove or fix the mod in question and continue. If you have only one savegame and run into an issue like this, you'll end up having to start from the beginning.


Signatur_zpsdlwsov7b.jpg


#10 Hassat Hunter

Hassat Hunter

    TSLRCM / M4-78EP Developer

  • Administrators
  • 4,510 posts

Posted 17 June 2017 - 05:27 PM

I'm just going to add having no text at all is likely a very *bad* thing rather than a good thing.

#11 Xr900

Xr900

    Jedi Apprentice

  • Members
  • PipPip
  • 12 posts

Posted 18 June 2017 - 11:57 AM

I have played M4-78 for couple hours now without any issues, but when I got to Archon chamber and I talked to IS-24, the game crashed when he said his line. I tried reloading the save multiple times and it always crashes at this particular moment. Any idea how to fix this?



#12 Hassat Hunter

Hassat Hunter

    TSLRCM / M4-78EP Developer

  • Administrators
  • 4,510 posts

Posted 18 June 2017 - 09:34 PM

Got a savegame?
Could be your install method though.

#13 Xr900

Xr900

    Jedi Apprentice

  • Members
  • PipPip
  • 12 posts

Posted 18 June 2017 - 09:43 PM

I guess copy-pasting 1.3 files from steam workshop might be the reason for this. Can I expect any issues with the modification if I *downgrade* M4-78 installation from copy-pasted steam workshop v1.3 files to proper patcher installation of v1.2?



#14 Kexikus

Kexikus

    Jedi Master

  • Members
  • PipPipPipPipPip
  • 1,225 posts

Posted 19 June 2017 - 06:04 AM

If you load a savegame from before going to M4-78 it should be fine. A savegame from before visiting the Archon Chamber for the first time might work as well if there are only issues in this particular module. All issues from other model are already baked into your savegame at this point, which is why a pre-M4-78 save would be the safest way to go (but could still cause issues).


Signatur_zpsdlwsov7b.jpg


#15 Sith Holocron

Sith Holocron

    M4-78

  • Administrators
  • 3,767 posts
  • LocationKodiak, AK (Hoth)

Posted 19 June 2017 - 12:49 PM

If you load a savegame from before going to M4-78 it should be fine. 

Please remember that he said he's been using a quick save the whole way through.


"Release dates are for those that don't care about quality in mods." - Me
My mods can be found here.

 

I tend not to accept friend requests from people that I don't know or if they lack a profile picture.


#16 Xr900

Xr900

    Jedi Apprentice

  • Members
  • PipPip
  • 12 posts

Posted 19 June 2017 - 01:16 PM

I actually had *hard save* before travelling to M4-78 (due to complications with Jedi Temple). But anyway, it worked, even from the point right before the conversation with IS-24. I *upgraded* it back to 1.3 afterward though because side quests weren't working anymore and IS-24 voice in 1.2 wasn't robotic yet. I guess if issues like this will happen again, I'll just manipulate the files the same way. But so far it's working normal and I've experienced no other crashes. This mod is quite long and interesting, I really like it.



#17 Hassat Hunter

Hassat Hunter

    TSLRCM / M4-78EP Developer

  • Administrators
  • 4,510 posts

Posted 19 June 2017 - 02:38 PM

Glad to hear so, don't forget to leave your impressions in the right topic once you're done :D
http://deadlystream....for-version-13/




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users